Bug #7627

Instance variables of a Struct object are marshaled even when marshal_dump method is defined.

Added by Kirill Lashuk over 2 years ago. Updated about 2 years ago.

[ruby-core:51163]
Status:Closed
Priority:Normal
Assignee:-
ruby -v:ruby 2.0.0dev (2012-11-01 trunk 37411) [x86_64-darwin12.2.0] Backport:

Description

=begin
If (({marshal_dump})) method is defined in a class and you pass an instance of that class into (({Marshal.dump})), instead of dumping instance variables (as it happens by default, when (({marshal_dump})) is not defined) Ruby dumps only data returned from this method.

Though, if the class is a (({Struct})), MRI 1.8.7 behaves the same way as for a regular class, but both MRI 1.9.3 and MRI 2.0.0 in addition to the data returned from (({marshal_dump})) method automatically dump instance variables of the object.

Code example:

# marshal.rb

class A
attr_accessor :foo

def marshal_dump; 'dump'; end # fake dump data
def marshal_load(*); end # do nothing
end

class B < Struct.new(:bar)
attr_accessor :foo

def marshal_dump; 'dump'; end # fake dump data
def marshal_load(*); end # do nothing
end

def test(obj)
obj.foo = 12

dump = Marshal.dump(obj)
loaded = Marshal.load(dump)

p obj, dump, loaded, loaded.foo
puts
end

test(A.new)
test(B.new)

MRI 1.8.7 (instance variable of the Struct object ((is not dumped))):

$ ruby-1.8.7-p371 marshal.rb
#
"\004\bU:\006A\"\tdump"
#
nil

#
"\004\bIU:\006B\"\tdump\000"
#
nil

MRI 1.9.3 (instance variable of the Struct object ((is dumped))):

$ ruby-1.9.3-p327 marshal.rb
#
"\x04\bU:\x06AI\"\tdump\x06:\x06EF"
#
nil

#
"\x04\bIU:\x06BI\"\tdump\x06:\x06EF\x06:\t@fooi\x11"
#
12

MRI 2.0.0-preview1 (instance variable of the Struct object ((is dumped))):

$ ruby-2.0.0-preview1 marshal.rb
#
"\x04\bU:\x06AI\"\tdump\x06:\x06EF"
#
nil

#
"\x04\bIU:\x06BI\"\tdump\x06:\x06EF\x06:\t@fooi\x11"
#
12

I'm not sure if it's expected behavior, but it doesn't look like one to me. Probably, it has something to do with the implementation of (({has_ivars})) macro that for some reason is used (()) while dumping an object with defined (({marshal_dump})) method, but I might be wrong, because I didn't manage to track down the problem further.

=end

Associated revisions

Revision 38952
Added by Nobuyoshi Nakada about 2 years ago

marshal.c: marshal_dump instance varialbes

  • marshal.c (w_object): dump instance varialbes of the result of marshal_dump not the original object. [Bug #7627]
  • complex.c (nucomp_marshal_dump): need to copy instance variables.
  • rational.c (nurat_marshal_dump): ditto.

Revision 38952
Added by Nobuyoshi Nakada about 2 years ago

marshal.c: marshal_dump instance varialbes

  • marshal.c (w_object): dump instance varialbes of the result of marshal_dump not the original object. [Bug #7627]
  • complex.c (nucomp_marshal_dump): need to copy instance variables.
  • rational.c (nurat_marshal_dump): ditto.

Revision 40392
Added by Nobuyoshi Nakada almost 2 years ago

marshal.c: use ivars of marshal_dump data

  • marshal.c (w_object): dump no ivars to the original by marshal_dump. [Bug #8276]
  • marshal.c (r_object0): copy all ivars of marshal_dump data to the result object instead. [Bug #7627]

Revision 40392
Added by Nobuyoshi Nakada almost 2 years ago

marshal.c: use ivars of marshal_dump data

  • marshal.c (w_object): dump no ivars to the original by marshal_dump. [Bug #8276]
  • marshal.c (r_object0): copy all ivars of marshal_dump data to the result object instead. [Bug #7627]

Revision 40408
Added by Nobuyoshi Nakada almost 2 years ago

marshal.c: fix marshal_load ivar

  • marshal.c (r_object0): copy all instance variables not only generic ivars, before calling post proc. [Bug #7627]

Revision 40408
Added by Nobuyoshi Nakada almost 2 years ago

marshal.c: fix marshal_load ivar

  • marshal.c (r_object0): copy all instance variables not only generic ivars, before calling post proc. [Bug #7627]

History

#1 Updated by Koichi Sasada about 2 years ago

I'm not sure about this issue, but is it high-priority trunk issue?
or not important issue?

#2 Updated by Nobuyoshi Nakada about 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r38952.
Kirill, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


marshal.c: marshal_dump instance varialbes

  • marshal.c (w_object): dump instance varialbes of the result of marshal_dump not the original object. [Bug #7627]
  • complex.c (nucomp_marshal_dump): need to copy instance variables.
  • rational.c (nurat_marshal_dump): ditto.

Also available in: Atom PDF