Project

General

Profile

Bug #7915

Rubygems stub shebang is wrongly expanded

Added by Vit Ondruch over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
ruby -v:
ruby 2.0.0dev (2013-02-14 trunk 39237) [x86_64-linux]
Backport:
[ruby-core:52715]

Description

=begin
Rubygems stub shebang is wrongly expanded. It used to be /usr/bin/ruby in rev39237 and now it is /bin/ruby in rev39387. It seems, that the --with-exec prefix is wrong handled, se
ruby -rrbconfig -e "RbConfig::CONFIG.each {|c| p c}"
output [1], where the 'exec_prefix' value is empty, where it used to contain /usr value. I guess that 39320 is the offending patch.

[1] https://gist.github.com/voxik/5016136
=end

History

#1 [ruby-core:52716] Updated by Vit Ondruch over 3 years ago

Reverting 39267 (part of 39320 backport) fixed the issue. Could you plase revert or provide better patch? Thank you.

#2 [ruby-core:52781] Updated by Yusuke Endoh over 3 years ago

  • Status changed from Open to Assigned
  • Target version set to 2.0.0

Nobu said he cannot repro.
Sorry, we have no time to consider this issue.
It may be fixed in a patch level release after 2.0.0-p0.

--
Yusuke Endoh mame@tsg.ne.jp

#3 [ruby-core:52788] Updated by Yusuke Endoh over 3 years ago

  • Target version changed from 2.0.0 to 2.1.0

#4 [ruby-core:54170] Updated by Vit Ondruch over 3 years ago

  • Status changed from Assigned to Closed

I cannot reproduce it with -p0, so it was probably fixed in the meantime.

#5 [ruby-core:54173] Updated by Vit Ondruch over 3 years ago

  • Status changed from Closed to Assigned

I couldn't reproduce the issue, since there is this patch applied in Fedora:

http://pkgs.fedoraproject.org/cgit/ruby.git/tree/ruby-2.0.0-revert-unexpand-exec-prefix.patch

So this is still relevant. Sorry for the noise :/

#6 [ruby-core:55424] Updated by Vit Ondruch about 3 years ago

  • Status changed from Assigned to Closed

This seems to be fixed in "ruby 2.0.0p195 (2013-05-14 revision 40734) [x86_64-linux]". Thanks.

Also available in: Atom PDF