Bug #8085

Debian configure failure because of nonexistent GCC flag -Werror=shorten-64-to-32

Added by mathew murphy about 1 year ago. Updated about 1 year ago.

[ruby-core:53385]
Status:Third Party's Issue
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:2.0.0p0 Backport:

Description

Trying to build Ruby 2.0.0 on Debian Stable:

ruby-2.0.0-p0/golfprelude.c
/tmp/ruby-build.20130313161606.17854/ruby-2.0.0-p0 /tmp/ruby-build.20130313161606.17854 ~
checking build system type... x86
64-unknown-linux-gnu
checking host system type... x8664-unknown-linux-gnu
checking target system type... x86
64-unknown-linux-gnu
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in /tmp/ruby-build.20130313161606.17854/ruby-2.0.0-p0':
configure: error: C compiler cannot create executables
See
config.log' for more details

In the config.log:

gcc version 4.4.5 (Debian 4.4.5-8)
configure:3721: $? = 0
configure:3710: gcc -V >&5
gcc: '-V' option must have argument
configure:3721: $? = 1
configure:3710: gcc -qversion >&5
gcc: unrecognized option '-qversion'
gcc: no input files
configure:3721: $? = 1
configure:3741: checking whether the C compiler works
configure:3763: gcc -Wno-error=shorten-64-to-32 -I'/home/meta/.rbenv/versions/2.0.0-p0/include' -L'/home/meta/.rbenv/versions/2.0.0-p0/lib' conftest.c >&5
cc1: error: -Werror=shorten-64-to-32: No option -Wshorten-64-to-32
configure:3767: $? = 1
configure:3805: result: no
configure: failed program was:
| /* confdefs.h /
| #define PACKAGENAME ""
| #define PACKAGE
TARNAME ""
| #define PACKAGEVERSION ""
| #define PACKAGE
STRING ""
| #define PACKAGEBUGREPORT ""
| #define PACKAGE
URL ""
| #define CANONICALIZATIONFORMATHN 1
| #define RUBYBASENAME "ruby" !!
| #define RUBYVERSIONNAME RUBYBASENAME"-"RUBYLIBVERSION !!
| /
end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:3810: error: in /tmp/ruby-build.20130313160124.17429/ruby-2.0.0-p0':
configure:3812: error: C compiler cannot create executables
See
config.log' for more details

I can't immediately see why ./configure decided to add -Werror=shorten-64-to-32. I've successfully built 2.0 on Ubuntu with GCC 4.6, and that doesn't have the -shorten-64-to-32 warning either.

History

#1 Updated by mathew murphy about 1 year ago

Oops! Turns out this is a bug in ruby-build:

https://github.com/sstephenson/ruby-build/issues/325

Sorry.

#2 Updated by Motohiro KOSAKI about 1 year ago

  • Status changed from Open to Rejected

Oops! Turns out this is a bug in ruby-build:

Then, closed.

#3 Updated by Nobuyoshi Nakada about 1 year ago

  • Status changed from Rejected to Third Party's Issue

Also available in: Atom PDF