Bug #8124

gem fails to install valid gems

Added by Ramkumar Ramachandra over 2 years ago. Updated 12 months ago.

[ruby-core:53537]
Status:Closed
Priority:Normal
Assignee:-
ruby -v:2.0.0p0 Backport:

Description

I'm not able to reproduce this, but many people have reported it on occasion.

$ gem install bundler
ERROR:  Could not find a valid gem 'bundler' (>= 0) in any repository
ERROR:  Possible alternatives: bundler

Can anyone confirm this?

History

#1 Updated by Hiroshi SHIBATA over 2 years ago

Please check results of "gem source" command.

#2 Updated by Ramkumar Ramachandra over 2 years ago

$ gem sources
*** CURRENT SOURCES ***

http://rubygems.org/

Like I said, I'm not able to reproduce the issue, even after a gem sources -c. The issue I'm pointing out here is that the error reported on the original issue is completely stupid and wrong- it should never be printed, no matter what the circumstance. Unfortunately, unless someone can figure out how to reproduce it, I see no way to make headway.

#3 Updated by Ayumu AIZAWA over 2 years ago

For handle this issue, it need to know occasion of that "many people".
If you are not "many people" and you could not reproduce such problem, we can not fix it as same as you.

#4 Updated by Ilya Vorontsov over 2 years ago

I periodically have similar but not the same issue.

gem install rails
ERROR: Could not find a valid gem 'rails' (>= 0), here is why:
Unable to download data from https://rubygems.org/ - SSL_connect SYSCALL returned=5 errno=0 state=SSLv2/v3 read server hello A (https://rubygems.org/latest_specs.4.8.gz)
ERROR: Possible alternatives: rails

gem sources shows me https://rubygems.org
I work with Windows system, ruby both version 1.9.3p0, 2.0.0p0, gem version 2.0.3, OpenSSL 1.0.1e(11 Feb 2013)
gem update also doesn't affect rails gem (while many other gems updated properly) and doesn't even show me that rails have more recent version (no error message at all).
If I explicitly select that I want update rails(gem update rails), updating works.
To be more complete, switching -v didn't solve my problem. Before that issue I've installed prerelease version of rails. I've tried to gem install rails with this prerelease version installed and with this version uninstalled.

#5 Updated by Steve Klabnik almost 2 years ago

I believe both of these errors happen when there are network problems of some kind, but haven't been able to reproduce in any meaningful way.

#6 Updated by Hiroshi SHIBATA over 1 year ago

  • Status changed from Open to Closed

#7 Updated by Gary Turner 12 months ago

I for one have got this error.
I have no idea what to do to solve it, and/or what the significance of it is. I've just installed ruby on windows 8 to run a project that I work on. I have installed a couple of gems, and now can't.

C:\Ruby193\bin>ruby -v
ruby 1.9.3p545 (2014-02-24) [i386-mingw32]

C:\Ruby193\bin>gem -v
1.8.28

C:\Ruby193\bin>gem install rgeo
ERROR: Could not find a valid gem 'rgeo' (>= 0) in any repository
ERROR: Possible alternatives: rgeo

C:\Ruby193\bin>gem install dbf
ERROR: Could not find a valid gem 'dbf' (>= 0) in any repository
ERROR: Possible alternatives: dbf

C:\Ruby193\bin>gem sources
*** CURRENT SOURCES ***

http://rubygems.org/

Also available in: Atom PDF