Project

General

Profile

Actions

Bug #8398

closed

case/when shouldn't try to evaluate all AND joined conditions if one of preceding was falsy

Added by goshakkk (Gosha Arinich) over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
1.9.3, 2.0.0
[ruby-core:54938]

Description

=begin

Steps to reproduce:

case 1
when String && proc { |x| x.blah }
:something
else
:no
end

Here is how I thought it works: goes to the first 'when', evals the first condition ((({1 === String}))), sees it's false and proceeds to the next (({when})) (or (({else}))) and happily returns (({:no})).

As it turns out, even if one of AND joined conditions was false, ruby would still try to eval other conditions, and as soon as it calls the block with 1, (({NoMethodError})) gets thrown as there is no (({#blah})) on Integer.

I believe this is incorrect behavior and conditions with AND in case/when should behave like everywhere else.

=end

Actions

Also available in: Atom PDF