Project

General

Profile

Feature #8600

Recognize variables declared in if modifier at end of line

Added by rudolph9 (Kurt Rudolph) over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
[ruby-core:55783]

Description

=begin
2.0.0 (main):0 > .ruby -v
ruby 2.0.0p195 (2013-05-14 revision 40734) [x86_64-darwin12.3.0]
2.0.0 (main):0 > ([0,1,2])[i] = 1.0 if i = ['seconds'].find_index('seconds')
NameError: undefined local variable or method i' for main:Object
from (pry):1:in
pry'

Is it possible to get rid of this kind of error? Especially since it doesn't matter what the value of the variable is so long as it's defined.

2.0.0 (main):0 > i = 10000
=> 10000
2.0.0 (main):0 > ([0,1,2])[i] = 1.0 if i = ['seconds'].find_index('seconds')
=> 1.0
=end


Related issues

Is duplicate of Ruby trunk - Feature #1141: assignment of variable in "right" if statement failsRejected02/11/2009Actions
Is duplicate of Ruby trunk - Feature #4965: The problem of "print line if line = DATA.gets"Rejected07/03/2011Actions
Is duplicate of Ruby trunk - Bug #6132: Assignments don't happen correctly in "if" modifiersRejected03/12/2012Actions

History

Updated by rosenfeld (Rodrigo Rosenfeld Rosas) over 5 years ago

A long-time +1, but if I remember correctly Matz doesn't want this because it could introduce backward incompatibility...

Updated by rosenfeld (Rodrigo Rosenfeld Rosas) over 5 years ago

Or maybe because it would be too complex to change the parser to support that? Now I'm not sure about the reasons...

Updated by matz (Yukihiro Matsumoto) over 5 years ago

  • Description updated (diff)
  • Status changed from Open to Rejected

Variables are declared in the order of appearance. I don't want to introduce exceptions.

Matz.

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Description updated (diff)

Also available in: Atom PDF