Project

General

Profile

Backport #8617

Backport RubyGems 2.0.5 to Ruby 2.0.0

Added by drbrain (Eric Hodel) over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:55896]

Description

RubyGems 2.0.4 contains only bug fixes. The release notes are here:

http://rubygems.rubyforge.org/rubygems-update/History_txt.html#label-2.0.4+%2F+2013-07-09

Attached is a patch to the ruby_2_0_0 branch as trunk contains mixed commits.


Files

rubygems.2_0_4.ruby.2_0_0.patch (36 KB) rubygems.2_0_4.ruby.2_0_0.patch drbrain (Eric Hodel), 07/10/2013 11:44 AM
rubygems.2_0_5.ruby.2_0_0.patch (33.2 KB) rubygems.2_0_5.ruby.2_0_0.patch drbrain (Eric Hodel), 07/12/2013 10:10 AM

Associated revisions

Revision b264a7ac
Added by nagachika (Tomoyuki Chikanaga) over 6 years ago

  • lib/rubygems: Update to RubyGems 2.0.5.
    The patch provided by drbrain (Eric Hodel). [ruby-core:55896]
    [Backport #8617]

  • test/rubygems: Tests for the above.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_0_0@42117 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 42117
Added by nagachika (Tomoyuki Chikanaga) over 6 years ago

  • lib/rubygems: Update to RubyGems 2.0.5.
    The patch provided by drbrain (Eric Hodel). [ruby-core:55896]
    [Backport #8617]

  • test/rubygems: Tests for the above.

History

Updated by drbrain (Eric Hodel) over 6 years ago

This updated patch contains rubygems 2.0.5 and is a complete patch to ruby_2_0_0

Updated by nagachika (Tomoyuki Chikanaga) over 6 years ago

  • Status changed from Open to Assigned
  • Assignee set to nagachika (Tomoyuki Chikanaga)

(just for memorandom)
The patch contains r41846, r41872.
r41857 is also required for Tracer test.
r41933 for rdoc.

Updated by nagachika (Tomoyuki Chikanaga) over 6 years ago

Hello, Eric.

Thank you for providing a patch.

BTW, do you have a plan to versioning of bundled RubyGems?
Currently RubyGems 2.1 is bundled in trunk.
In 2.0.0, bundled RubyGems' version will be 2.0.x, or migrate to RubyGems 2.1 in future?
In other words, RubyGems 2.0.x series are continuously maintained?

Updated by drbrain (Eric Hodel) over 6 years ago

I plan to continue to maintain 2.0.x series (I have two bugs to fix for a 2.0.6 release). RubyGems 2.0.x has had small, easy to fix bugs, so this is not difficult for me.

I do not believe RubyGems 2.1 and newer should be backported to Ruby 2.0.0 as it will add new features.

#5

Updated by nagachika (Tomoyuki Chikanaga) over 6 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r42117.
Eric, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


  • lib/rubygems: Update to RubyGems 2.0.5.
    The patch provided by drbrain (Eric Hodel). [ruby-core:55896]
    [Backport #8617]

  • test/rubygems: Tests for the above.

Also available in: Atom PDF