Project

General

Profile

Bug #8715

openssl mkmf.log filled with other data

Added by mpapis (Michal Papis) about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin12.3.0]
[ruby-core:56298]

Description

=begin
After compilation + installation of ruby I check the log: (({cat /Users/mpapis/.rvm/src/ruby-2.0.0-p247/ext/openssl/mkmf.log}))
Failed to configure openssl. It will not be installed.
Failed to configure -test-/win32/dln. It will not be installed.
Failed to configure -test-/win32/fd_setsize. It will not be installed.
Failed to configure dl/win32. It will not be installed.
Failed to configure fiddle/win32. It will not be installed.

Then I run: (({(cd /Users/mpapis/.rvm/src/ruby-2.0.0-p247/ext/openssl/ ; ruby extconf.rb )}))
checking for t_open() in -lnsl... no
checking for socket() in -lsocket... no
checking for assert.h... yes
checking for openssl/ssl.h... yes
checking for openssl/conf_api.h... yes
checking for SSL_library_init() in openssl/ssl.h with -Werror=deprecated-declarations... no
extconf.rb:62:in <main>': Ignore OpenSSL broken by Apple. (RuntimeError)
Please use another openssl. (e.g. using
configure --with-openssl-dir=/path/to/openssl')

And check the log again: (({cat /Users/mpapis/.rvm/src/ruby-2.0.0-p247/ext/openssl//mkmf.log}))

=== OpenSSL for Ruby configurator ===
=== Checking for system dependent stuff... ===
have_library: checking for t_open() in -lnsl... -------------------- no

"/usr/bin/clang -o conftest -I/Users/mpapis/.rvm/rubies/ruby-2.0.0-p247/include/ruby-2.0.0/x86_64-darwin12.3.0 -I/Users/mpapis/.rvm/rubies/ruby-2.0.0-p247/include/ruby-2.0.0/ruby/backward -I/Users/mpapis/.rvm/rubies/ruby-2.0.0-p247/include/ruby-2.0.0 -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT -D_REENTRANT -O3 -I/Users/mpapis/.sm/pkg/active/include -fPIC -pipe conftest.c -L. -L/Users/mpapis/.rvm/rubies/ruby-2.0.0-p247/lib -L. -Z -L/Users/mpapis/.sm/pkg/active/lib -L/usr/lib -fPIC -Bstatic -fstack-protector -arch x86_64 -lruby-static -lpthread -ldl -lobjc "
...

Is this intended behavior or a bug?
=end


Related issues

Is duplicate of Backport200 - Backport #8209: mkmf.log contains misplaced messagesClosednagachika (Tomoyuki Chikanaga)04/03/2013Actions

Updated by mpapis (Michal Papis) about 7 years ago

=begin
After applying http://www.rubyist.net/~eban/goto/r42213 from https://bugs.ruby-lang.org/issues/7948

The error changes to: (({cat /Users/mpapis/.rvm/src/ruby-2.0.0-p247/ext/openssl//mkmf.log}))

Ignore OpenSSL broken by Apple.
Please use another openssl. (e.g. using `configure --with-openssl-dir=/path/to/openssl')
Failed to configure openssl. It will not be installed.

And again i need to run (({ruby extconf.rb})) to see more details in the log.
=end

Updated by akr (Akira Tanaka) about 7 years ago

2013/8/1 mpapis (Michal Papis) mpapis@gmail.com:

Bug #8715: openssl mkmf.log filled with other data
https://bugs.ruby-lang.org/issues/8715

After compilation + installation of ruby I check the log: (({cat /Users/mpapis/.rvm/src/ruby-2.0.0-p247/ext/openssl/mkmf.log}))
Failed to configure openssl. It will not be installed.
Failed to configure -test-/win32/dln. It will not be installed.
Failed to configure -test-/win32/fd_setsize. It will not be installed.
Failed to configure dl/win32. It will not be installed.
Failed to configure fiddle/win32. It will not be installed.

r40080 on trunk may fix mkmf.log. (not tested with Ruby 2.0.0)
--
Tanaka Akira

Updated by mpapis (Michal Papis) about 7 years ago

yes it did fixed the log problem - please backport it

Updated by nagachika (Tomoyuki Chikanaga) about 7 years ago

  • Status changed from Open to Closed

Hello,

I'd backported r40080 and r40081 to ruby_2_0_0.

Also available in: Atom PDF