Backport #9169

`require': cannot load such file -- date_core (LoadError) (ruby-2.0.0-p353)

Added by Yasuhiro Nakayama over 1 year ago. Updated over 1 year ago.

[ruby-dev:47823]
Status:Closed
Priority:Normal
Assignee:Tomoyuki Chikanaga

Description

When building ruby-2.0.0-p353, the following message appeared.

Searching for files in directory /var/tmp/ruby-2.0.0-p353
Version of /var/tmp/ruby-2.0.0-p353/addr2line.c : /var/tmp/ruby-2.0.0-p353/.ext/common/date.rb:3:in require': cannot load such file -- date_core (LoadError)
from /var/tmp/ruby-2.0.0-p353/.ext/common/date.rb:3:in
'
from /var/tmp/ruby-2.0.0-p353/lib/time.rb:1:in require'
from /var/tmp/ruby-2.0.0-p353/lib/time.rb:1:in
'
from /var/tmp/ruby-2.0.0-p353/tool/vcs.rb:3:in require'
from /var/tmp/ruby-2.0.0-p353/tool/vcs.rb:3:in
'
from ./tool/file2lastrev.rb:7:in require'
from ./tool/file2lastrev.rb:7:in
'
no version available

I think need to resolve this problem, load path required. For example,

diff --git a/tool/file2lastrev.rb b/tool/file2lastrev.rb
index 56e1b9f..d17ae24 100755
--- a/tool/file2lastrev.rb
+++ b/tool/file2lastrev.rb
@@ -1,5 +1,6 @@
#!/usr/bin/env ruby

+$:.unshift File.join(File.dirname(__FILE__), '..', 'ext', 'lib', 'date')
require 'optparse'

# this file run with BASERUBY, which may be older than 1.9, so no

logs.txt Magnifier (578 KB) Yasuhiro Nakayama, 11/28/2013 11:43 AM

Associated revisions

Revision 43888
Added by Nobuyoshi Nakada over 1 year ago

common.mk: use BASERUBY

  • common.mk (Doxyfile): tool/file2lastrev.rb needs running with BASERUBY since r43617. [Bug #9169]

Revision 43904
Added by Tomoyuki Chikanaga over 1 year ago

merge revision(s) 43888: [Backport #9169]

* common.mk (Doxyfile): tool/file2lastrev.rb needs running with
  BASERUBY since r43617.   [Bug #9169]

History

#1 Updated by Nobuyoshi Nakada over 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r43888.
Yasuhiro, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


common.mk: use BASERUBY

  • common.mk (Doxyfile): tool/file2lastrev.rb needs running with BASERUBY since r43617. [Bug #9169]

#2 Updated by Yasuhiro Nakayama over 1 year ago

Wow, thank you for your quick response!
I hope this change backporting to branch ruby_2_0_0 of svn repo.
Can I help you?

#3 Updated by Nobuyoshi Nakada over 1 year ago

  • Category set to build
  • Status changed from Closed to Assigned
  • Assignee set to Nobuyoshi Nakada
  • % Done changed from 100 to 0
  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: REQUIRED

#4 Updated by Tomoyuki Chikanaga over 1 year ago

  • Tracker changed from Bug to Backport
  • Project changed from Ruby trunk to Backport200
  • Category deleted (build)
  • Assignee changed from Nobuyoshi Nakada to Tomoyuki Chikanaga

Thank you for your report! It's a regression of 2.0.0-p353. I'll backport it soon.

#5 Updated by Tomoyuki Chikanaga over 1 year ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r43904.
Yasuhiro, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


merge revision(s) 43888: [Backport #9169]

* common.mk (Doxyfile): tool/file2lastrev.rb needs running with
  BASERUBY since r43617.   [Bug #9169]

Also available in: Atom PDF