Bug #9317

--with-opt-dirがLDFLAGS, DLDFLAGSに反映されない

Added by Wataru Kimura about 1 year ago. Updated about 1 year ago.

[ruby-dev:47868]
Status:Closed
Priority:Normal
Assignee:Nobuyoshi Nakada
ruby -v:ruby 2.2.0dev (2013-12-29 trunk 44457) [x86_64-darwin13.0] Backport:1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

Description

./configureに--with-opt-dirで与えたパスがCPPFLAGSには設定されますが、
LDFLAGSとDLDFLAGSに設定されません。

opt-dirの処理をしている時点で、LIBPATHFLAGやRPATHFLAGに値がまだないためだと思います。

trunkと2.1で発生しています。2.0では起きません。

Associated revisions

Revision 44476
Added by Nobuyoshi Nakada about 1 year ago

configure.in: LDFLAGS and DLDFLAGS for opt-dir

  • configure.in: reset LDFLAGS and DLDFLAGS for opt-dir again after LIBPATHFLAG and RPATHFLAG are set. [Bug #9317]

Revision 44476
Added by Nobuyoshi Nakada about 1 year ago

configure.in: LDFLAGS and DLDFLAGS for opt-dir

  • configure.in: reset LDFLAGS and DLDFLAGS for opt-dir again after LIBPATHFLAG and RPATHFLAG are set. [Bug #9317]

History

#1 Updated by Nobuyoshi Nakada about 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r44476.
Wataru, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


configure.in: LDFLAGS and DLDFLAGS for opt-dir

  • configure.in: reset LDFLAGS and DLDFLAGS for opt-dir again after LIBPATHFLAG and RPATHFLAG are set. [Bug #9317]

#2 Updated by Yui NARUSE about 1 year ago

  • Backport changed from 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

Also available in: Atom PDF