Bug #9326

No superclass method in ruby 2.1

Added by Nate Mueller over 1 year ago. Updated about 1 year ago.

[ruby-core:59417]
Status:Closed
Priority:Normal
Assignee:-
ruby -v:ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin13.0] Backport:

Description

Runing ruby 2.1 plus nobu's patch from issue 9315. Without the patch it segfaults.

Found this testing testing test-redef with ruby 2.1. Works on 2.0.0-p353 and fails on 2.1.0. When the replacement method calls the alias directly it works but when we fetch the method and #call it the mixin can't super up.

test.rb Magnifier (492 Bytes) Nate Mueller, 12/31/2013 06:33 AM

History

#1 Updated by Nobuyoshi Nakada over 1 year ago

Does it work on the trunk?

#2 Updated by _ wanabe over 1 year ago

Seems to be fine on ruby_2_1, after r44410 (merging r44380).
I confirmed NoMethodError is raised on 2.1.0 (r44340) and not on ruby_2_1 (r44443).

But 'ruby -v' of this ticket is revision 44422 (> 44410).
Really test.rb fails on r44422? I can't figure out what happens.

#3 Updated by Nate Mueller over 1 year ago

Confirmed that it works on trunk. Looks like the fix was r44458. It still fails on ruby_2_1.

I can't explain the 'ruby -v' discrepancy. I did a fresh download of 2.1.0 and confirmed that's what it reports.

#4 Updated by Hiroshi SHIBATA over 1 year ago

I created backport issue #9349 for Ruby 2.1.

#5 Updated by Hiroshi SHIBATA about 1 year ago

  • Status changed from Open to Closed

ruby_2_1 fixed this issue. Please wait until next release of Ruby 2.1

Also available in: Atom PDF