Project

General

Profile

Bug #9334

activesupport-4.0.2/lib/active_support/dependencies.rb:229: [BUG] Segmentation fault at 0x00000000000018

Added by malagodia (Andrea Malagodi) almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.1.0
Backport:
[ruby-core:59443]

Description

I have just upgraded to ruby 2.1.0 and running in Rails foreman (unicorn) and received a long error report, which I quite frankly do not understand, attached an output and diagnostics report


Files

log.txt (240 KB) log.txt malagodia (Andrea Malagodi), 01/01/2014 08:41 AM
ruby_2013-12-31-213242_MALMBP.crash (32.9 KB) ruby_2013-12-31-213242_MALMBP.crash malagodia (Andrea Malagodi), 01/01/2014 08:41 AM
log.txt (248 KB) log.txt malagodia (Andrea Malagodi), 01/07/2014 05:23 AM

Related issues

Is duplicate of Ruby master - Bug #9309: Crash while running testsClosed12/27/2013Actions

History

Updated by malagodia (Andrea Malagodi) almost 6 years ago

Noted that same issue, I think, is reported in issue #9309

Updated by hsbt (Hiroshi SHIBATA) almost 6 years ago

  • Status changed from Open to Feedback

Could you try to trunk version of Ruby?

Updated by malagodia (Andrea Malagodi) almost 6 years ago

I have attempted with ruby 2.1.0 head ruby 2.1.1p2 (2013-12-31 revision 44467) [x86_64-darwin13.0]

The same issue is encountered

Updated by tmm1 (Aman Gupta) almost 6 years ago

This issue is resolved on trunk, but has not been backported to 2.1 yet. Please confirm on trunk instead of ruby_2_1

Updated by malagodia (Andrea Malagodi) almost 6 years ago

I confirm that on ruby 2.2.0dev (2014-01-10 trunk 44548) the issue is resolved

#6

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Is duplicate of Bug #9309: Crash while running tests added
#7

Updated by hsbt (Hiroshi SHIBATA) almost 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF