Project

General

Profile

Bug #9309

Crash while running tests

Added by mdemare (Michiel de Mare) almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:59343]

Description

I got the following crash while running a test suite.

/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229: [BUG] Segmentation fault at 0x00000000000018
ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin13.0]

-- Crash Report log information --------------------------------------------
See Crash Report log file under the one of following:
* ~/Library/Logs/CrashReporter
* /Library/Logs/CrashReporter
* ~/Library/Logs/DiagnosticReports
* /Library/Logs/DiagnosticReports
for more details.

-- Control frame information -----------------------------------------------
c:0029 p:0012 s:0106 e:000103 BLOCK /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229
c:0028 p:0060 s:0102 e:000101 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214
c:0027 p:0019 s:0097 e:000096 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229 [FINISH]
c:0026 p:---- s:0092 e:000091 IFUNC
c:0025 p:---- s:0090 e:000089 CFUNC :glob
c:0024 p:0033 s:0086 e:000085 TOP /Users/mdemare/proj/tolq/core/lib/core/factories.rb:1 [FINISH]
c:0023 p:---- s:0084 e:000083 CFUNC :require
c:0022 p:0012 s:0080 e:000079 BLOCK /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229
c:0021 p:0060 s:0078 e:000077 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214
c:0020 p:0019 s:0073 e:000072 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229
c:0019 p:0009 s:0068 e:000067 TOP /Users/mdemare/proj/tolq/core/spec/factories.rb:1 [FINISH]
c:0018 p:---- s:0066 e:000065 CFUNC :load
c:0017 p:0014 s:0061 e:000060 BLOCK /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223
c:0016 p:0060 s:0059 e:000058 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214
c:0015 p:0023 s:0054 e:000053 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223
c:0014 p:0034 s:0048 e:000047 BLOCK /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/factory_girl-4.3.0/lib/factory_girl/find_definitions.rb:16 [FINISH]
c:0013 p:---- s:0045 e:000044 CFUNC :each
c:0012 p:0023 s:0042 e:000041 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/factory_girl-4.3.0/lib/factory_girl/find_definitions.rb:15
c:0011 p:0270 s:0038 e:000037 TOP /Users/mdemare/proj/tolq/core/spec/spec_helper.rb:33 [FINISH]
c:0010 p:---- s:0036 e:000035 CFUNC :require
c:0009 p:0007 s:0032 e:000031 TOP /Users/mdemare/proj/tolq/core/spec/lib/core/translation_publishing/fetcher_spec.rb:1 [FINISH]
c:0008 p:---- s:0030 e:000029 CFUNC :load
c:0007 p:0018 s:0026 e:000025 BLOCK /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/configuration.rb:896 [FINISH]
c:0006 p:---- s:0023 e:000022 CFUNC :each
c:0005 p:0011 s:0020 e:000019 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/configuration.rb:896
c:0004 p:0054 s:0017 e:000016 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/command_line.rb:22
c:0003 p:0101 s:0012 e:000011 METHOD /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/runner.rb:80
c:0002 p:0044 s:0005 e:000004 BLOCK /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/runner.rb:17 [FINISH]
c:0001 p:0000 s:0002 E:001e78 TOP [FINISH]

/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/runner.rb:17:in block in autorun'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/runner.rb:80:in
run'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/command_line.rb:22:in run'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/configuration.rb:896:in
load_spec_files'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/configuration.rb:896:in each'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/configuration.rb:896:in
block in load_spec_files'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/rspec-core-2.14.7/lib/rspec/core/configuration.rb:896:in load'
/Users/mdemare/proj/tolq/core/spec/lib/core/translation_publishing/fetcher_spec.rb:1:in
'
/Users/mdemare/proj/tolq/core/spec/lib/core/translation_publishing/fetcher_spec.rb:1:in require'
/Users/mdemare/proj/tolq/core/spec/spec_helper.rb:33:in
'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/factory_girl-4.3.0/lib/factory_girl/find_definitions.rb:15:in find_definitions'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/factory_girl-4.3.0/lib/factory_girl/find_definitions.rb:15:in
each'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/factory_girl-4.3.0/lib/factory_girl/find_definitions.rb:16:in block in find_definitions'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in
load'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214:in load_dependency'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in
block in load'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:223:in load'
/Users/mdemare/proj/tolq/core/spec/factories.rb:1:in
'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229:in require'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214:in
load_dependency'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229:in block in require'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229:in
require'
/Users/mdemare/proj/tolq/core/lib/core/factories.rb:1:in <top (required)>'
/Users/mdemare/proj/tolq/core/lib/core/factories.rb:1:in
glob'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229:in require'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:214:in
load_dependency'
/Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/activesupport-4.0.2/lib/active_support/dependencies.rb:229:in `block in require'

-- C level backtrace information -------------------------------------------
0 ruby 0x000000010d32199d rb_vm_bugreport + 141
1 ruby 0x000000010d1ebd3d report_bug + 285
2 ruby 0x000000010d1ebc13 rb_bug + 179
3 ruby 0x000000010d2aa609 sigsegv + 153
4 libsystem_platform.dylib 0x00007fff9593d5aa _sigtramp + 26
5 ruby 0x000000010d30fb45 rb_method_entry_get_without_cache + 181
6 ??? 0x00007fff52a4a150 0x0 + 140734579908944

-- Other runtime information -----------------------------------------------

  • Loaded script: /Users/mdemare/.rbenv/versions/2.1.0/bin/rspec

  • Loaded features:

    0 enumerator.so
    1 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/x86_64-darwin13.0/enc/encdb.bundle
    2 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/x86_64-darwin13.0/enc/trans/transdb.bundle
    3 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/x86_64-darwin13.0/rbconfig.rb
    4 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/compatibility.rb
    5 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/defaults.rb
    6 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/deprecate.rb
    7 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/errors.rb
    8 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/version.rb
    9 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/requirement.rb
    10 /Users/mdemare/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/platform.rb


Files

ruby_2.1.0.crash.log (28 KB) ruby_2.1.0.crash.log crash log mdemare (Michiel de Mare), 12/30/2013 06:54 PM

Related issues

Has duplicate Ruby master - Bug #9334: activesupport-4.0.2/lib/active_support/dependencies.rb:229: [BUG] Segmentation fault at 0x00000000000018Closed01/01/2014Actions
Has duplicate Ruby master - Bug #9313: Segmentation fault with active_recordClosed12/28/2013Actions
Has duplicate Ruby master - Bug #9315: Segfault when calling super in rspec mocks with and_call_original [linux]Closed12/28/2013Actions
Has duplicate Ruby master - Bug #9391: Segfault after upgrade from ruby 2.0 to 2.1Closed01/10/2014Actions
Has duplicate Ruby master - Bug #9310: inheritance.rb: 27: [BUG] Segmentation fault at 0x00000cClosed12/28/2013Actions
Has duplicate Ruby master - Bug #9461: SegfaultClosed01/29/2014Actions

History

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Status changed from Open to Feedback

Please attach a Crash Report log file.

Updated by tmm1 (Aman Gupta) almost 6 years ago

Can you try to reproduce this with trunk? This issue should be resolved with r44458 (dupe of #9315).

Updated by marciotrindade (Marcio Trindade) almost 6 years ago

Hi,

I had the same problem and reported in #9313.
I tested with r44487 and it's working now.

Thank you

Updated by zzak (Zachary Scott) almost 6 years ago

  • Status changed from Feedback to Closed

fixed by r44458

#6

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Has duplicate Bug #9334: activesupport-4.0.2/lib/active_support/dependencies.rb:229: [BUG] Segmentation fault at 0x00000000000018 added
#7

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Has duplicate Bug #9313: Segmentation fault with active_record added
#8

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Has duplicate Bug #9315: Segfault when calling super in rspec mocks with and_call_original [linux] added
#9

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Related to Bug #9391: Segfault after upgrade from ruby 2.0 to 2.1 added
#10

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Related to deleted (Bug #9391: Segfault after upgrade from ruby 2.0 to 2.1)
#11

Updated by nobu (Nobuyoshi Nakada) almost 6 years ago

  • Has duplicate Bug #9391: Segfault after upgrade from ruby 2.0 to 2.1 added

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Related to Bug #9310: inheritance.rb: 27: [BUG] Segmentation fault at 0x00000c added

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Related to deleted (Bug #9310: inheritance.rb: 27: [BUG] Segmentation fault at 0x00000c)

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Has duplicate Bug #9310: inheritance.rb: 27: [BUG] Segmentation fault at 0x00000c added

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

Updated by usa (Usaku NAKAMURA) over 5 years ago

  • Backport changed from 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: UNKNOWN

Also available in: Atom PDF