Project

General

Profile

Actions

Bug #9391

closed

Segfault after upgrade from ruby 2.0 to 2.1

Added by lars.vonk@gmail.com (Lars Vonk) over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.0
Backport:

Description

Hi,

I also this message on the rubyforum but no reaction so far, therefor I am posting here as well. I upgraded our Sinatra app to ruby 2.1 and running our tests immediately result in a segfault. Attached my dependencies with versions and the full error message. Maybe someone can check if this has got to do with ruby 2.1 or one of my gems. I can't figure out were to start looking. Any pointers are helpful.

Thanks in advance,

Lars


Files

Gemfile.lock.txt (7.4 KB) Gemfile.lock.txt My gems lars.vonk@gmail.com (Lars Vonk), 01/10/2014 07:15 PM
segfault.txt (179 KB) segfault.txt Full segfault trace lars.vonk@gmail.com (Lars Vonk), 01/10/2014 07:15 PM

Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #9309: Crash while running testsClosed12/27/2013Actions
Actions #1

Updated by hsbt (Hiroshi SHIBATA) over 8 years ago

  • Tracker changed from Backport to Bug
  • Project changed from Backport21 to Ruby master
  • ruby -v set to ruby 2.1.0
Actions #2

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Related to Bug #9309: Crash while running tests added
Actions #3

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Related to deleted (Bug #9309: Crash while running tests)
Actions #4

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Is duplicate of Bug #9309: Crash while running tests added
Actions #5

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF