Project

General

Profile

Bug #9555

Ruby 2.0.0 compilation fails to compile on cygwin. (curses.so)

Added by dajoen (Jeroen Verhoeven) about 5 years ago. Updated over 4 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.0.0
Backport:
[ruby-core:61017]

Description

Using RVM we see that ruby fails to compile for 2.0.0. This seems to be fixed in 2.1.0.
Compiling the 2.1.0 as follows succeeds:
rvm --debug install 2.1.0 --without-tcl --without-tk

Trying the same for 2.0.0 fails. With errors logged in the following gist: https://gist.github.com/dajoen/8933735#file-second-attempt-modified-diff-file

A history of events can also be seen in https://github.com/wayneeseguin/rvm/issues/2360.

History

Updated by hsbt (Hiroshi SHIBATA) over 4 years ago

  • Tracker changed from Backport to Bug
  • Project changed from Backport200 to Ruby trunk
  • ruby -v set to 2.0.0

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Status changed from Open to Feedback

Could you show ext/curses/mkmf.log and ext/curses/extconf.h files?

Also available in: Atom PDF