Project

General

Profile

Bug #9643

error on install dir contain space .

Added by sevk (kk kk) over 5 years ago. Updated 7 days ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.0.0p451 (2014-02-24) [x64-mingw32]
[ruby-core:61527]

Description

invalid switch in RUBYOPT: -F (RuntimeError)

error on install dir contain space .

http://stackoverflow.com/questions/16898286/error-invalid-switch-in-rubyopt-f-runtimeerror-is-shown-while-install-gems

History

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Category changed from platform/windows to lib/rubygems
  • Status changed from Open to Assigned
  • Assignee changed from cruby-windows to drbrain (Eric Hodel)

Seems it is caused by Gem::Ext::ExtConfBuilder.build.
It insert -r#{siteconf_path} to RUBYOPT, and the path is cwd, which is under the installed gem directory.

I'd suggest to use just base name in RUBYOPT and pass cwd by RUBYLIB instead.

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

If build never accept -C option, just "-r#{siteconf.path}" is enough.

Updated by jeremyevans0 (Jeremy Evans) 7 days ago

  • Status changed from Assigned to Closed

This should be fixed by 4de117a61517e839f2c45eaf45d56fc243d6d5b2, which updated to Rubygems 2.4.1 and removed the use of RUBYOPT from Gem::Ext::ExtConfBuilder.build.

Also available in: Atom PDF