Project

General

Profile

Feature #9778

Bring shortcut methods to Hash

Added by natesymer (Nathaniel Symer) over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Target version:
[ruby-core:62179]

Description

My obsession with easy syntax annoys me when I see Hash#merge does not have a shortcut in the form of a mathematical operation (like - or +).

h_one = { :foo => "bar", :this => "that", :all => "nothing" }
h_two = { :foo => "this", :ruby => "awesome" }

# this isn't as pretty
h_one.merge(h_two)
  =>  { :foo => "this", :this => "that", :all => "nothing", :ruby => "awesome" }

# as this
h_one+h_two
  => { :foo => "this", :this => "that", :all => "nothing", :ruby => "awesome" }`

Why doesn't this exist in Ruby?


Related issues

Is duplicate of Ruby trunk - Feature #6225: Hash#+Rejected2012-03-30

History

#1 [ruby-core:62181] Updated by bitsweat (Jeremy Daer) over 3 years ago

Hash#+ rejected in #6225. Also see #7739 for Hash#|.

#2 [ruby-core:62182] Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Description updated (diff)

#3 [ruby-core:62183] Updated by nobu (Nobuyoshi Nakada) over 3 years ago

#4 [ruby-core:62185] Updated by nobu (Nobuyoshi Nakada) over 3 years ago

#5 [ruby-core:62187] Updated by nobu (Nobuyoshi Nakada) over 3 years ago

#6 [ruby-core:62189] Updated by nobu (Nobuyoshi Nakada) over 3 years ago

  • Status changed from Open to Rejected

Also available in: Atom PDF