Project

General

Profile

Feature #9893

[RFC] README.EXT: document rb_gc_register_mark_object

Added by normalperson (Eric Wong) about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-core:62902]

Description

ref [ruby-core:62862]

Any comment on officially supporting this as part of the C API?

diff --git a/README.EXT b/README.EXT
index d66d6c5..dded850 100644
--- a/README.EXT
+++ b/README.EXT
@@ -1176,6 +1176,12 @@ void rb_global_variable(VALUE *var)

Tells GC to protect these variables.

+void rb_gc_register_mark_object(VALUE val)
+

  • Tells GC to protect the object referenced by val. This requires less
  • memory to track than rb_global_variable, but may only be used if the C == Constant Definition

void rb_define_const(VALUE klass, const char *name, VALUE val) ::


Related issues

Is duplicate of Ruby master - Feature #9894: [RFC] README.EXT: document rb_gc_register_mark_objectClosedActions

Updated by nagachika (Tomoyuki Chikanaga) almost 6 years ago

  • Status changed from Open to Assigned

Updated by nagachika (Tomoyuki Chikanaga) almost 6 years ago

  • Is duplicate of Feature #9894: [RFC] README.EXT: document rb_gc_register_mark_object added

Updated by nagachika (Tomoyuki Chikanaga) almost 6 years ago

  • Status changed from Assigned to Closed

sorry for noise. This is duplicated ticket (#9894)

Also available in: Atom PDF