Project

General

Profile

Bug #10288

Parser incompatibility between 2.1.2 and 2.1.3

Added by matsuda (Akira Matsuda) over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.1.3p242 (2014-09-19 revision 47630) [x86_64-darwin12.0]
Backport:
[ruby-core:65249]

Description

This code successfully prints {:foo=>1} in 2.1.2 and current trunk but causes "syntax error, unexpected modifier_if" in 2.1.3

p({foo: if true then 1 end})

Related issues

Is duplicate of Ruby trunk - Bug #10279: Syntax error on Hash with symbol syntax and nested expression: 2.1.3 regression Closed09/22/2014Actions

History

Updated by matsuda (Akira Matsuda) over 4 years ago

  • Assignee changed from matz (Yukihiro Matsumoto) to nagachika (Tomoyuki Chikanaga)
  • Target version deleted (2.2.0)

Updated by matsuda (Akira Matsuda) over 4 years ago

  • Status changed from Open to Closed

Oops! I'm sorry, looks like this dups with #10279

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Is duplicate of Bug #10279: Syntax error on Hash with symbol syntax and nested expression: 2.1.3 regression added

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Backport deleted (2.0.0: UNKNOWN, 2.1: REQUIRED)

Also available in: Atom PDF