Project

General

Profile

Bug #10639

Unable to update/download gems (wrong number of arguments)

Added by duerst (Martin Dürst) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 2.2.0dev (2014-12-24 trunk 48957) [x86_64-cygwin]
[ruby-core:67086]

Description

When I run make up; make install-nodoc
I get the following error. I suspect it is related to recent changes.

make[1]: Entering directory '/cygdrive/c/Data/ruby-public'
config.guess already exists
config.sub already exists
Downloading bundled gem files...
downloading  ... /cygdrive/c/Data/ruby-public/lib/open-uri.rb:364:in `initialize': wrong number of arguments (1 for 2) (ArgumentError)
        from /cygdrive/c/Data/ruby-public/tool/downloader.rb:110:in `exception'
        from /cygdrive/c/Data/ruby-public/tool/downloader.rb:110:in `raise'
        from /cygdrive/c/Data/ruby-public/tool/downloader.rb:110:in `rescue in download'
        from /cygdrive/c/Data/ruby-public/tool/downloader.rb:57:in `download'
        from /cygdrive/c/Data/ruby-public/tool/downloader.rb:13:in `download'
        from -e:4:in `<main>'
uncommon.mk:914: recipe for target 'update-gems' failed
make[1]: *** [update-gems] Error 1
make[1]: Leaving directory '/cygdrive/c/Data/ruby-public'
uncommon.mk:904: recipe for target 'up' failed
make: [up] Error 2 (ignored)
compiling version.c

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Description updated (diff)
  • Status changed from Open to Assigned
  • Assignee changed from naruse (Yui NARUSE) to nobu (Nobuyoshi Nakada)
  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED

It's since r47694.

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Applied in changeset r48963.


downloader.rb: fix exception arguments

  • tool/downloader.rb (Downloader.download): fix the exception to re-raise. initialize methods of subclasses of Exception may have different parameters. [ruby-core:67086] [Bug #10639]

Updated by naruse (Yui NARUSE) over 5 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE

Also available in: Atom PDF