Project

General

Profile

Bug #11080

[PERF] bm_so_concatenate.rb regression

Added by tgxworld (Guo Xiang Tan) almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.3.0dev (2015-04-17 trunk 50336) [x86_64-linux]
[ruby-core:<unknown>]

Description

http://rubybench.org/ruby/ruby/commits?result_type=so_concatenate&display_count=1000

Hi, I spotted a regression on bm_so_concatenate.rb due to https://github.com/ruby/ruby/commit/b3626b3.

Before b3626b3: 2.665s
After b3626b3: 5.377s

Do let me know if there are more information that I can provide to help out with this issue. Thank you in advance!


Related issues

Is duplicate of Ruby trunk - Bug #11095: severe performance regression since r50336ClosedActions

Associated revisions

Revision 2b0a6f47
Added by nobu (Nobuyoshi Nakada) almost 4 years ago

revert r50336

  • string.c (str_buf_cat): expand later so that the buffer can be larger for further use. [Bug #11080] [Bug #11080]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@50386 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50386
Added by nobu (Nobuyoshi Nakada) almost 4 years ago

revert r50336

  • string.c (str_buf_cat): expand later so that the buffer can be larger for further use. [Bug #11080] [Bug #11080]

Revision 50386
Added by nobu (Nobuyoshi Nakada) almost 4 years ago

revert r50336

  • string.c (str_buf_cat): expand later so that the buffer can be larger for further use. [Bug #11080] [Bug #11080]

Revision 50386
Added by nobu (Nobuyoshi Nakada) almost 4 years ago

revert r50336

  • string.c (str_buf_cat): expand later so that the buffer can be larger for further use. [Bug #11080] [Bug #11080]

Revision 50386
Added by nobu (Nobuyoshi Nakada) almost 4 years ago

revert r50336

  • string.c (str_buf_cat): expand later so that the buffer can be larger for further use. [Bug #11080] [Bug #11080]

Revision 50386
Added by nobu (Nobuyoshi Nakada) almost 4 years ago

revert r50336

  • string.c (str_buf_cat): expand later so that the buffer can be larger for further use. [Bug #11080] [Bug #11080]

History

#1

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

  • Related to Bug #11095: severe performance regression since r50336 added
#2

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

  • Related to deleted (Bug #11095: severe performance regression since r50336)
#3

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

  • Is duplicate of Bug #11095: severe performance regression since r50336 added
#4

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Applied in changeset r50386.


revert r50336

  • string.c (str_buf_cat): expand later so that the buffer can be larger for further use. [Bug #11080] [Bug #11080]

Updated by tgxworld (Guo Xiang Tan) almost 4 years ago

Thank you for your work Nobu!

#6

Updated by usa (Usaku NAKAMURA) almost 4 years ago

  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONTNEED

Also available in: Atom PDF