Project

General

Profile

Bug #11209

[PATCH] Fix for String#+ when subclassed

Added by yoongkang (Yoong Kang Lim) over 4 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:69446]

Description

See #10845.

I also have a Github PR at https://github.com/ruby/ruby/pull/920.


Files

0001-Fix-String-when-subclassed.patch (1.48 KB) 0001-Fix-String-when-subclassed.patch yoongkang (Yoong Kang Lim), 06/04/2015 01:25 AM

Related issues

Is duplicate of Ruby master - Bug #10845: Subclassing StringOpenActions

History

#2

Updated by yoongkang (Yoong Kang Lim) over 4 years ago

  • File deleted (diff.patch)

Updated by yoongkang (Yoong Kang Lim) over 4 years ago

My apologies, just realised the previous patch file was in the wrong format. Uploaded a new patch.

#4

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Is duplicate of Bug #10845: Subclassing String added

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

I think it is a spec, and there must be more duplicate issues here but can't find them now.

Updated by yoongkang (Yoong Kang Lim) over 4 years ago

You mean the original behaviour was intentional?

#7

Updated by jeremyevans0 (Jeremy Evans) 5 months ago

  • Status changed from Open to Closed

Also available in: Atom PDF