Project

General

Profile

Bug #11284

String#upcase and String#downcase don't work for accented characters

Added by pabloh (Pablo Herrero) almost 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-linux]
[ruby-core:69666]

Description

Many accented and other non-english characters fails to upcase/downcase properly.
Accented characters is the most common are the ones I keep stumbling upon,, but probably other germanic/nordic characters I'm not aware of have the same problems.

For example:

"Hola, ¿Cómo estás?".upcase         # returns "HOLA, ¿CóMO ESTáS?"
"CONFIANÇA".downcase                # returns "confianÇa"
"Un moment s'il vous plaît".upcase  # returns "UN MOMENT S'IL VOUS PLAîT"

Related issues

Is duplicate of CommonRuby - Feature #10085: Add non-ASCII case conversion to String#upcase/downcase/swapcase/capitalizeClosedduerst (Martin Dürst)Actions

Also available in: Atom PDF