Project

General

Profile

Feature #11308

Optional `include_super=true` parameter for `*method_defined?` methods

Added by sawa (Tsuyoshi Sawada) about 5 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:69741]

Description

I request the following methods in the Module class:

  • method_defined?
  • private_method_defined?
  • protected_method_defined?
  • public_method_defined?

to take an optional include_super parameter with the default value true, and work similar to the methods:

  • instance_methods
  • private_instance_methods
  • protected_instance_methods
  • and public_instance_methods

Updated by matz (Yukihiro Matsumoto) about 5 years ago

Rationale? I don't see any real-world use-case for them.

Matz.

Updated by sawa (Tsuyoshi Sawada) 7 months ago

This is another duplicate of #10797. Please close this issue.

#3

Updated by Eregon (Benoit Daloze) 7 months ago

  • Status changed from Open to Closed

Also available in: Atom PDF