Project

General

Profile

Bug #11553

Disable by default the DTrace support on Linux systems.

Added by clopez (Carlos Alberto Lopez Perez) over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0dev (2015-09-26 trunk 51943) [x86_64-linux]
[ruby-core:<unknown>]

Description

The issue is the following:

So, I propose to (by default) disable dtrace support on Linux systems.

Otherwise users that try to build Ruby on a Linux system with dtrace4Linux installed (me for example), will end with a broken build.

Linux users willing to try this feature, can still pass the --enable-dtrace flag to enable it.

Patch attached.


Files

Disable-by-default-the-dtrace-support-on-Linux-syste.patch (1.5 KB) Disable-by-default-the-dtrace-support-on-Linux-syste.patch Patch that disables by default DTrace support on Linux systems. clopez (Carlos Alberto Lopez Perez), 09/26/2015 04:17 PM

History

#1

Updated by vo.x (Vit Ondruch) over 3 years ago

There is SystemTap which works just fine. And if you don't have installed /usr/bin/dtrace, then it will be disabled anyway. So to say, I am against disabling.

#2

Updated by shevegen (Robert A. Heiler) over 3 years ago

I assume that users will have to use --disable-dtrace to be on the safe side.

It is always a problem with binary yes/no enabling options since there is no middle ground in such a situation.

Ruby in general tries to enable whatever is available on the host system, if it can be found. I am not sure for
which programs this would not be the case but I assume that e. g. just about all the entries in ext/ subdirectory
work like that.

#3

Updated by kosaki (Motohiro KOSAKI) over 3 years ago

If some distro doesn't support SystemTap and does support dtrace4linux officially, I'm ok to disable dtrace feature only on such distros. In the other hands, I have no seen any sense to disable it on Fedora/RHEL/CentOS.

I'm not sure Ubuntu's policy, though.

#4

Updated by nobu (Nobuyoshi Nakada) over 3 years ago

Then disable it if only dtrace4Linux is available?
How can we know SystemTap from dtrace4Linux?

#5

Updated by kosaki (Motohiro KOSAKI) over 3 years ago

Then disable it if only dtrace4Linux is available?

I still doubt no such distribution, though.

#6

Updated by clopez (Carlos Alberto Lopez Perez) over 3 years ago

Ok...

I didn't knew systemtap provided a dtrace binary, neither that it can use the DTrace probes just fine. I just tested it and it worked. Very interesting stuff.

So, I agree that is best keep the default as currently is.

I think dtrace4linux is not shipped with any distro by default. I (Debian user) had to build and install from sources myself.

I think we can close this bug as wontfix/invalid. I would do it myself, but it seems I don't have the required permissions to change the bug status.

#7

Updated by vo.x (Vit Ondruch) over 3 years ago

  • Status changed from Open to Rejected

Also available in: Atom PDF