Project

General

Profile

Bug #12154

Backport r54010 (avoid a setgid test on AIX)

Added by ReiOdaira (Rei Odaira) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:74207]

Description

This is a ticket to back-port r54010 to 2.1, 2.2, and 2.3.

Associated revisions

Revision 560c2da3
Added by usa (Usaku NAKAMURA) over 3 years ago

merge revision(s) 54010: [Backport #12154]

    * test/ruby/test_process.rb (test_execopts_gid): Skip a test
      that is known to fail on AIX. AIX allows setgid to
      a supplementary group, but Ruby does not allow the "-e"
      option when setgid'ed, so the test does not work as intended.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@54269 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54269
Added by usa (Usaku NAKAMURA) over 3 years ago

merge revision(s) 54010: [Backport #12154]

* test/ruby/test_process.rb (test_execopts_gid): Skip a test
  that is known to fail on AIX. AIX allows setgid to
  a supplementary group, but Ruby does not allow the "-e"
  option when setgid'ed, so the test does not work as intended.

Revision d8eb164a
Added by nagachika (Tomoyuki Chikanaga) over 3 years ago

merge revision(s) 54010: [Backport #12154]

    * test/ruby/test_process.rb (test_execopts_gid): Skip a test
      that is known to fail on AIX. AIX allows setgid to
      a supplementary group, but Ruby does not allow the "-e"
      option when setgid'ed, so the test does not work as intended.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@54328 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54328
Added by nagachika (Tomoyuki Chikanaga) over 3 years ago

merge revision(s) 54010: [Backport #12154]

* test/ruby/test_process.rb (test_execopts_gid): Skip a test
  that is known to fail on AIX. AIX allows setgid to
  a supplementary group, but Ruby does not allow the "-e"
  option when setgid'ed, so the test does not work as intended.

Revision cdb968ac
Added by naruse (Yui NARUSE) over 3 years ago

merge revision(s) 54010: [Backport #12154]

    * test/ruby/test_process.rb (test_execopts_gid): Skip a test
      that is known to fail on AIX. AIX allows setgid to
      a supplementary group, but Ruby does not allow the "-e"
      option when setgid'ed, so the test does not work as intended.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@54375 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54375
Added by naruse (Yui NARUSE) over 3 years ago

merge revision(s) 54010: [Backport #12154]

* test/ruby/test_process.rb (test_execopts_gid): Skip a test
  that is known to fail on AIX. AIX allows setgid to
  a supplementary group, but Ruby does not allow the "-e"
  option when setgid'ed, so the test does not work as intended.

History

Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Backport changed from 2.1: REQUIRED, 2.2: REQUIRED, 2.3: REQUIRED to 2.1: DONE, 2.2: REQUIRED, 2.3: REQUIRED

ruby_2_1 r54269 merged revision(s) 54010.

Updated by nagachika (Tomoyuki Chikanaga) over 3 years ago

  • Backport changed from 2.1: DONE, 2.2: REQUIRED, 2.3: REQUIRED to 2.1: DONE, 2.2: DONE, 2.3: REQUIRED

Backported into ruby_2_2 branch at r54328.

Updated by naruse (Yui NARUSE) over 3 years ago

  • Backport changed from 2.1: DONE, 2.2: DONE, 2.3: REQUIRED to 2.1: DONE, 2.2: DONE, 2.3: DONE

ruby_2_3 r54375 merged revision(s) 54010.

Also available in: Atom PDF