Project

General

Profile

Bug #12827

Add Boolean data type.

Added by ioquatix (Samuel Williams) over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:77546]

Description

It's not clear to me why there isn't a Boolean class which can have values true and false.

There are benefits to this. An example of where this is an issue is people who write ORM. For example, in sequel gem, they use "TrueClass" for a boolean column.

The naming of TrueClass and FalseClass are also inconsistent with other names, e.g. it's not IntegerClass or FloatClass or StringClass.


Related issues

Is duplicate of Ruby trunk - Feature #12515: Create "Boolean" superclass of TrueClass / FalseClassRejectedActions

History

#1

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

  • Is duplicate of Feature #12515: Create "Boolean" superclass of TrueClass / FalseClass added

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

  • Status changed from Open to Rejected

Do you have anything to add to https://bugs.ruby-lang.org/issues/12515 ?

Also available in: Atom PDF