Project

General

Profile

Bug #1324

Imap Tests hanging

Added by cfis (Charlie Savage) about 10 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.2dev (2009-03-29) [i386-mswin32_90]
Backport:
[ruby-core:23052]

Description

=begin
Ruby built with VC2008. Two tests, test_starttls and test_unexpected_eof hang. Tracing through the debugger, the two threads are in loops that call select and then go to sleep. They never come out of it. Note that changing the server = TCPServer.new(0) to server = TCPServer.new("localhost") allows the tests to run, but then:

ruby net\imap\test_imap.rb

1) Failure:
test_imaps_post_connection_check(IMAPTest) [net/imap/test_imap.rb:59]:
[OpenSSL::SSL::SSLError] exception expected, not
Class:
Message: <"getaddrinfo: The specified class was not found. ">
---Backtrace---
net/imap/test_imap.rb:118:in initialize'
net/imap/test_imap.rb:118:in
new'
net/imap/test_imap.rb:118:in imaps_test'
net/imap/test_imap.rb:60:in
block in test_imaps_post_connection_check'


2) Failure:
test_imaps_unknown_ca(IMAPTest) [net/imap/test_imap.rb:23]:
[OpenSSL::SSL::SSLError] exception expected, not
Class:
Message: <"getaddrinfo: The specified class was not found. ">
---Backtrace---
net/imap/test_imap.rb:118:in initialize'
net/imap/test_imap.rb:118:in
new'
net/imap/test_imap.rb:118:in imaps_test'
net/imap/test_imap.rb:24:in
block in test_imaps_unknown_ca'


3) Failure:
test_imaps_verify_none(IMAPTest) [net/imap/test_imap.rb:47]:
Exception raised:
<#>.

4) Failure:
test_imaps_with_ca_file(IMAPTest) [net/imap/test_imap.rb:35]:
Exception raised:
<#>.

5) Error:
test_starttls(IMAPTest):
SocketError: getaddrinfo: The specified class was not found.
net/imap/test_imap.rb:156:in initialize'
net/imap/test_imap.rb:156:in
new'
net/imap/test_imap.rb:156:in starttls_test'
net/imap/test_imap.rb:72:in
test_starttls'

6) Error:
test_unexpected_eof(IMAPTest):
SocketError: getaddrinfo: The specified class was not found.
net/imap/test_imap.rb:85:in initialize'
net/imap/test_imap.rb:85:in
new'
net/imap/test_imap.rb:85:in `test_unexpected_eof'
=end

Associated revisions

Revision 59991b6a
Added by hsbt (Hiroshi SHIBATA) over 3 years ago

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@51801 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 51801
Added by hsbt (Hiroshi SHIBATA) over 3 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) over 3 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) over 3 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) over 3 years ago

Revision 51801
Added by hsbt (Hiroshi SHIBATA) over 3 years ago

History

#1

Updated by yugui (Yuki Sonoda) almost 10 years ago

  • Assignee set to usa (Usaku NAKAMURA)
  • Target version changed from 1.9.1 to 1.9.2

=begin

=end

#2

Updated by usa (Usaku NAKAMURA) almost 10 years ago

  • Status changed from Open to Feedback

=begin
I cannot reproduce now...
Can you reproduce?
=end

#3

Updated by usa (Usaku NAKAMURA) over 9 years ago

  • Priority changed from Normal to 3

=begin

=end

#4

Updated by wanabe (_ wanabe) about 9 years ago

  • Status changed from Feedback to Rejected

=begin
I can't reproduce too, and this issue has no feedback for more than half a year.
So, I set the status "Rejected" temporarily.
If someone can reproduce even now, please inform and/or reopen the issue.
=end

Also available in: Atom PDF