Project

General

Profile

Actions

Feature #13272

closed

Keyword argument to instantiate a subclass of Struct

Added by tagomoris (Satoshi TAGOMORI) about 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:79885]

Description

When we define a subclass of Struct, it take arguments of values of fields when instantiated:

ServiceAccount = Struct(:account_name, :full_name, :nickname, :name_invited_by, :twitter_account_name)
a = ServiceAccount.new("tagomoris", "satoshi tagomori", "satoshi", "satoru", "@tagomoris")

It's simple and enough easy to use when the code to instantiate it is near from definition.
But sometimes the code using ServiceAccount may be far from definition, and hard to read/understand what does an element represent.

I want to use keyword arguments to instantiate struct objects in such case. it's far easier to understand rather than arguments without keywords:

a = ServiceAccount.new(
  account_name: "tagomoris",
  full_name: "satoshi tagomori",
  nickname: "satoshi",
  name_invited_by: "satoru",
  twitter_account_name: "@tagomoris",
)

Related issues

Is duplicate of Ruby master - Feature #11925: Struct construction with kwargsClosedActions
Actions #1

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

  • Is duplicate of Feature #11925: Struct construction with kwargs added

Updated by shevegen (Robert A. Heiler) about 4 years ago

I agree it is easier to read.

In the other thread, Shyouhei Urabe said that nobody at the developer
meeting was against it (I assume this also includes matz).

So I suppose that this may be implemented eventually.

Actions #3

Updated by k0kubun (Takashi Kokubun) over 3 years ago

  • Status changed from Open to Closed

Applied in changeset trunk|r61137.


struct.c: add keyword_init option to Struct.new

to initialize struct with keyword arguments.

[Feature #11925] [close GH-1771]

Actions

Also available in: Atom PDF