Project

General

Profile

Feature #13694

Add Tau constant to Math

Added by jzakiya (Jabari Zakiya) over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:81816]

Description

Today (June 28) is Tau Day! to honor the true circle constant tau = 2*pi = 6.28.

Michael Hartl (https://tauday.com/tau-manifesto) sent out an email today, to,
remind people that it's Tau Day, with the news that Python has now included the
tau constant in its Math Module.

http://bugs.python.org/issue12345

Now we can't let Python have all the fun and beat Ruby!

Please include the tau constant in Ruby's Math Module, to show it's tautally cool too! :)


Related issues

Related to Ruby master - Feature #4897: Define Math::TAU and BigMath.TAU. The "true" circle constant, Tau=2*Pi. See http://tauday.com/RejectedActions

History

Updated by jeremyevans0 (Jeremy Evans) over 2 years ago

  • Status changed from Open to Rejected

Duplicate of #4897, which matz rejected 7 months ago.

#2

Updated by naruse (Yui NARUSE) over 2 years ago

  • Related to Feature #4897: Define Math::TAU and BigMath.TAU. The "true" circle constant, Tau=2*Pi. See http://tauday.com/ added

Also available in: Atom PDF