Project

General

Profile

Bug #14188

With install Ruby 2.4.3 and Passenger 5.1.12 ALL sites will fail to open

Added by Sega100500 (Сергей Е) about 2 years ago. Updated about 2 years ago.

Status:
Third Party's Issue
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.4.3
[ruby-core:84284]

Description

With install Ruby 2.4.3 and Passenger 5.1.12 ALL sites will fail to open

https://github.com/phusion/passenger/issues/2010

Answer:

Hi, this doesn't look like an issue with Passenger, but instead with Ruby, see the error message:

App 21106 stderr:
/home/ruby/.rbenv/versions/2.4.3/lib/ruby/gems/2.4.0/gems/therubyracer-0.12.3/lib/v8/context.rb:99: [BUG] Segmentation fault at 0x0000000000000000
App 21106 stderr: ruby 2.4.3p205 (2017-12-14 revision 61247)
...
App 21106 stderr: [NOTE]
App 21106 stderr: You may have encountered a bug in the Ruby interpreter or extension libraries.
App 21106 stderr: Bug reports are welcome.
App 21106 stderr: For details: http://www.ruby-lang.org/bugreport.html


Files

passenger-log.z02 (1 MB) passenger-log.z02 Sega100500 (Сергей Е), 12/15/2017 10:00 AM
passenger-log.z01 (1 MB) passenger-log.z01 Sega100500 (Сергей Е), 12/15/2017 10:00 AM
passenger-log.zip (247 KB) passenger-log.zip Sega100500 (Сергей Е), 12/15/2017 10:00 AM

Related issues

Related to Ruby master - Bug #14238: With install Ruby 2.5.0 and Passenger 5.1.12 ALL sites will fail to openThird Party's IssueActions
#1

Updated by Sega100500 (Сергей Е) about 2 years ago

  • Backport deleted (2.3: UNKNOWN, 2.4: UNKNOWN)
  • ruby -v deleted (2.4.3)
  • Project changed from Ruby master to CommonRuby
  • Tracker changed from Bug to Feature
#2

Updated by Sega100500 (Сергей Е) about 2 years ago

  • Backport set to 2.3: UNKNOWN, 2.4: UNKNOWN
  • ruby -v set to 2.4.3
  • Project changed from CommonRuby to Ruby master
  • Tracker changed from Feature to Bug

Updated by shevegen (Robert A. Heiler) about 2 years ago

I have difficulty opening the zip files on my linux box.

It tells me:

warning [/Depot/jjjj/passenger-log.zip]: zipfile claims to be last disk of a multi-part archive;
attempting to process anyway, assuming all parts have been concatenated
together in order. Expect "errors" and warnings...true multi-part support
doesn't exist yet (coming soon).
file #1: bad zipfile offset (local header sig): 4

Updated by usa (Usaku NAKAMURA) about 2 years ago

  • Status changed from Open to Third Party's Issue

The SEGV point is therubyracer's script.Run() at https://github.com/cowboyd/therubyracer/blob/master/lib/v8/context.rb#L99 , furthermore, in V8 engine of therubyracer.

Sorry to send you around, but please report this issue to therubyracer.

#5

Updated by hsbt (Hiroshi SHIBATA) about 2 years ago

  • Related to Bug #14238: With install Ruby 2.5.0 and Passenger 5.1.12 ALL sites will fail to open added

Also available in: Atom PDF