Project

General

Profile

Bug #1500

test_io runs forever in windows

Added by rogerdpack (Roger Pack) about 11 years ago. Updated about 9 years ago.

Status:
Third Party's Issue
Priority:
Normal
Target version:
ruby -v:
TRUNK
Backport:
[ruby-core:23517]

Description

=begin
Don't know if this is expected, but running

loop {a << IO.pipe; }

runs forever in windows (from test_dup_many).
Thanks!
-=r
=end


Related issues

Related to Ruby master - Bug #373: MingwでIO#dupがブロックするClosednobu (Nobuyoshi Nakada)Actions
#1

Updated by jonco (Jon Coppeard) about 11 years ago

=begin
I am seeing this too.

Ruby version: ruby-1.9.1-p129
Cygwin version: CYGWIN_NT-5.1 1.5.25(0.156/4/2) 2008-06-12 19:34
Windows version: Windows XP Professional Ver 5.1 Build 2600 Service Pack 2

If I remove test_io, then all other tests pass.

Cheers,

Jon
=end

#2

Updated by rogerdpack (Roger Pack) about 11 years ago

=begin

If I remove test_io, then all other tests pass.

They all pass? no failures?
Thanks.
-=r
=end

#3

Updated by yugui (Yuki Sonoda) almost 11 years ago

  • Assignee set to usa (Usaku NAKAMURA)
  • Target version set to 1.9.2

=begin

=end

#4

Updated by usa (Usaku NAKAMURA) almost 11 years ago

  • Assignee changed from usa (Usaku NAKAMURA) to nobu (Nobuyoshi Nakada)

=begin
cygwin.
=end

#5

Updated by rogerdpack (Roger Pack) almost 11 years ago

=begin
Note that this occurs on non cygwin as well.
=end

#6

Updated by hperkins (Hal Perkins) almost 11 years ago

=begin
Also observed on Mac OS X 10.5.7 with Ruby 1.9.1-p243. After building with defaults (no options to configure or make), all tests pass except for #226, test_io.rb. That test fails with the message "not finished in 10 seconds [ruby-dev:32566]"
=end

#7

Updated by rogerdpack (Roger Pack) over 10 years ago

=begin
Turns out not to be that

loop {a << IO.pipe; }

runs forever in mingw, but that IO#dup in mingw hangs the process if it is called once, fails, and is called again (same fd).
I'm going to ping the mingw people about it.
Until then could someone please apply the patch to add a timeout, from 373? Otherwise make test-all hangs in mingw.
Thanks!
-r
=end

#8

Updated by rogerdpack (Roger Pack) over 10 years ago

  • Status changed from Open to Third Party's Issue

=begin
Turns out to be a bug in msvcrt.dll [I think].
=end

Also available in: Atom PDF