Project

General

Profile

Bug #1558

test timeout issues in windows

Added by rogerdpack (Roger Pack) about 11 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
"2009-05-28"
Backport:
[ruby-core:23674]

Description

=begin
Appears that a few tests (at least on my lowly windows box) timeout instead of raising the right error--or perhaps drb is indeed broke on windows?
Thanks!
-=r

12) Failure:
test_field_size_limit_controls_lookahead(TestCSVParsing)
[c:/dev/downloads/ruby_trunk/test/csv/test_csv_parsing.rb:178]:
[CSV::MalformedCSVError] exception expected, not
Class: Timeout::Error
Message: <"execution expired">
---Backtrace---
c:/dev/downloads/ruby_trunk/test/csv/test_csv_parsing.rb:187:in block
(2 levels) in assert_parse_errors_out'
c:/dev/downloads/ruby_trunk/test/csv/test_csv_parsing.rb:186:in
block
in assert_parse_errors_out'
c:/dev/downloads/ruby_trunk/test/csv/test_csv_parsing.rb:185:in
assert_parse_errors_out'
c:/dev/downloads/ruby_trunk/test/csv/test_csv_parsing.rb:178:in
test_field_size_limit_controls_lookahead'


13) Failure:
test_03(TestDRbCore) [c:/dev/downloads/ruby_trunk/test/drb/drbtest.rb:143]:
[ArgumentError] exception expected, not
Class: DRb::DRbConnError
Message: <"An existing connection was forcibly closed by the remote host.">
---Backtrace---
c:/dev/downloads/ruby_trunk/test/drb/drbtest.rb:144:in block in test_03'
c:/dev/downloads/ruby_trunk/test/drb/drbtest.rb:143:in
test_03'


14) Failure:
test_04_many_arg(TestDRbLarge)
[c:/dev/downloads/ruby_trunk/test/drb/test_drb.rb:286]:
[ArgumentError] exception expected, not
Class: DRb::DRbConnError
Message: <"An existing connection was forcibly closed by the remote host.">
---Backtrace---
c:/dev/downloads/ruby_trunk/test/drb/test_drb.rb:286:in block in
test_04_many_arg'
c:/dev/downloads/ruby_trunk/test/drb/test_drb.rb:286:in
test_04_many_arg'


=end

#1

Updated by yugui (Yuki Sonoda) almost 11 years ago

  • Assignee set to nobu (Nobuyoshi Nakada)
  • Target version set to 1.9.2

=begin

=end

#2

Updated by usa (Usaku NAKAMURA) about 10 years ago

  • Status changed from Open to Feedback

=begin
cannot reproduce now.
Roger, can you?
=end

#3

Updated by mame (Yusuke Endoh) about 10 years ago

=begin
Hi, Roger

Could you answer to unak?

--
Yusuke Endoh mame@tsg.ne.jp
=end

#4

Updated by rogerdpack (Roger Pack) about 10 years ago

=begin
the first two seem to not reproduce. The last is now:

C:\dev\ruby\downloads>\installs\ruby_trunk_no_patches_installed\bin\ruby ruby_trunk_no_patches\test\drb\test_drb.rb
Loaded suite ruby_trunk_no_patches/test/drb/test_drb
Started
..........F............F..........................
Finished in 22.975571 seconds.

1) Failure:
test_03(TestDRbCore) [C:/dev/ruby/downloads/ruby_trunk_no_patches/test/drb/drbtest.rb:138]:
[ArgumentError] exception expected, not
Class: DRb::DRbConnError
Message: <"An existing connection was forcibly closed by the remote host.">
---Backtrace---
C:/dev/ruby/downloads/ruby_trunk_no_patches/test/drb/drbtest.rb:139:in block in test_03'
C:/dev/ruby/downloads/ruby_trunk_no_patches/test/drb/drbtest.rb:138:in
test_03'


2) Failure:
test_04_many_arg(TestDRbLarge) [ruby_trunk_no_patches/test/drb/test_drb.rb:286]:
[ArgumentError] exception expected, not
Class: DRb::DRbConnError
Message: <"An existing connection was forcibly closed by the remote host.">
---Backtrace---
ruby_trunk_no_patches/test/drb/test_drb.rb:287:in block in test_04_many_arg'
ruby_trunk_no_patches/test/drb/test_drb.rb:286:in
test_04_many_arg'


50 tests, 278 assertions, 2 failures, 0 errors, 0 skips

ruby 1.9.3dev (2010-05-08) [i386-mingw32]
Thanks!
=end

#5

Updated by mame (Yusuke Endoh) about 10 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from nobu (Nobuyoshi Nakada) to usa (Usaku NAKAMURA)

=begin

=end

#6

Updated by usa (Usaku NAKAMURA) about 10 years ago

  • Status changed from Assigned to Closed

=begin
Ok, closing.
=end

Also available in: Atom PDF