Project

General

Profile

Actions

Bug #15604

closed

Backport r66349 to 2.5

Added by rafaelfranca (Rafael França) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:91534]

Description

Revision r66349 fixes a bug that was causing byebug to not reliable work if your code was using Fowardable.

See also https://bugs.ruby-lang.org/issues/15303


Related issues

Is duplicate of Ruby master - Bug #15303: Return tracepoint doesn't fire when tailcall optimization is appliedClosedActions

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

  • Status changed from Open to Closed

(Changing status to closed, which would trigger the backporting process. Don't take it as a rejection.)

Updated by rafaelfranca (Rafael França) over 2 years ago

Thank you! Do you need to change the backport field to point it needs to be backported to 2.5 but not to 2.6?

Updated by shyouhei (Shyouhei Urabe) over 2 years ago

rafaelfranca (Rafael França) wrote:

Thank you! Do you need to change the backport field to point it needs to be backported to 2.5 but not to 2.6?

Thank you. But leaving that field UNKNOWN is just OK.

Actions #4

Updated by nagachika (Tomoyuki Chikanaga) over 2 years ago

  • Is duplicate of Bug #15303: Return tracepoint doesn't fire when tailcall optimization is applied added
Actions #5

Updated by nagachika (Tomoyuki Chikanaga) over 2 years ago

  • Backport changed from 2.4: UNKNOWN, 2.5: UNKNOWN, 2.6: UNKNOWN to 2.4: UNKNOWN, 2.5: REQUIRED, 2.6: DONTNEED
Actions

Also available in: Atom PDF