Project

General

Profile

Bug #1576

TestFile failures in windows

Added by rogerdpack (Roger Pack) over 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3dev (2010-05-12 trunk 27746) [i386-mswin32]
Backport:
[ruby-core:23723]

Description

=begin
Here ya go:

18) Failure:
test_gets_para_extended_file(TestFile)
[c:/dev/downloads/ruby_trunk/test/ruby/test_file.rb:94]:
mode = <>.
<"a"> expected but was
<"\na">.

19) Failure:
test_expand_path(TestFileExhaustive)
[c:/dev/downloads/ruby_trunk/test/ruby/test_file_exhaustive.rb:389]:
ArgumentError expected but nothing was raised.

20) Failure:
test_stat(TestFileExhaustive)
[c:/dev/downloads/ruby_trunk/test/ruby/test_file_exhaustive.rb:80]:
expected but was
.

21) Failure:
test_stat_init(TestFileExhaustive)
[c:/dev/downloads/ruby_trunk/test/ruby/test_file_exhaustive.rb:558]:
expected but was
.

22) Failure:
test_utime(TestFileExhaustive)
[c:/dev/downloads/ruby_trunk/test/ruby/test_file_exhaustive.rb:338]:
expected but was
.

Not so sure about that last one.
Thanks!
-=r
=end

Associated revisions

Revision 6f3791f4
Added by usa (Usaku NAKAMURA) over 9 years ago

[Bug #1576]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@27769 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision fab26158
Added by usa (Usaku NAKAMURA) over 9 years ago

merge from trunk (r27768-r27770)

  • io.c (swallow): support text mode and UTF-16/32 as internal encoding.
    [Bug #1576]

  • io.c (io_shift_cbuf): read and throw it away when str is NULL.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_2@27771 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

History

#1

Updated by yugui (Yuki Sonoda) over 10 years ago

  • Assignee set to nobu (Nobuyoshi Nakada)

=begin

=end

#2

Updated by usa (Usaku NAKAMURA) over 9 years ago

  • Category set to core
  • Status changed from Open to Assigned
  • Target version set to 1.9.2
  • ruby -v changed from TRUNK mingw to ruby 1.9.3dev (2010-05-12 trunk 27746) [i386-mswin32]

=begin
19) - 21) is already fixed (or changed the test)
cannot reproduce 22). maybe fixed.

18) is the problem of paragraph mode of IO#gets.
if the newline code is not equals as 0x0A, paragraph mode doesn't run well.
I think to change the function swallow() in io.c.
=end

#3

Updated by rogerdpack (Roger Pack) over 9 years ago

=begin
yeah the only TestFile failures I currently get is:

34) Failure:test_gets_para_extended_file(TestFile) [C:/dev/ruby/downloads/ruby_trunk_no_patches/test/ruby/test_file.rb:94]:mode = <>.<"a"> expected but was<"\na">.

(from http://gist.github.com/396251)

Thanks for looking into that!
-rp
=end

#4

Updated by usa (Usaku NAKAMURA) over 9 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r27769.
Roger, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF