Project

General

Profile

Actions

Feature #15894

closed

Remove support for IA64

Added by ioquatix (Samuel Williams) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-core:92923]

Description

There are many #ifdef __ia64 in Ruby code base. At one point it must have been supported.

But as an architecture, it's EOL (Jan 30th 2019). Last CPU was released in 2017.

I can't even buy 2nd hand CPU for testing.

So, I propose we remove support for IA64.

The main motivation for me personally is I want to simplify and improve fiber implementation. But it's impossible for me to test IA64 architecture.


Related issues

Related to Ruby master - Feature #18491: Drop support for IBM AIX and HP UXClosedActions
Actions

Also available in: Atom PDF