Project

General

Profile

Actions

Bug #18147

closed

URI is not loaded anymore since ruby-2.7.0

Added by sascha (Sascha Willuweit) 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:105131]

Description

It's not a big thing but may break things: Starting with ruby-2.7.0 the URI module is not auto-loaded. Please check/reproduce this using ruby -e "URI" since ruby-2.7.0
it throws an uninitialized constant URI (NameError) whereas in previous ruby releases it simply passes.

I have no clue which things have changed from 2.6.6 to 2.7.0 that are causing this unusual behaiviour...

Updated by sascha (Sascha Willuweit) 3 months ago

Wow, that was fast. Thanks! The problem is, that it changes the behavior between plain ruby and any wrapper like irb. But nevertheless, it's certainly not a ruby but a rubygems issue. So this bug report can be closed.

Updated by hsbt (Hiroshi SHIBATA) 3 months ago

  • Status changed from Open to Closed

It's expected behavior and changes.

You should require "uri" or -ruri for using URI library.

Updated by deivid (David Rodríguez) 3 months ago

Wow, that was fast. Thanks! The problem is, that it changes the behavior between plain ruby and any wrapper like irb. But nevertheless, it's certainly not a ruby but a rubygems issue. So this bug report can be closed.

I created a pull request to rubygems so that irb doesn't change default ruby behaviour regarding uri being loaded: https://github.com/rubygems/rubygems/pull/4897.

Actions

Also available in: Atom PDF