Project

General

Profile

Actions

Misc #18687

closed

[ANN] Upgraded bugs.ruby-lang.org to Redmine 5.0

Added by hsbt (Hiroshi SHIBATA) 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
[ruby-core:<unknown>]

Description

Today, I migrated this tracker Redmine 4.2 to 5.0.

It has the following major changes.

  • Based on Rails 6.1.
  • Allowed username mention like @hsbt with autocomplete.
  • Support CommonMaker for Markdown formatting.

Release note is here: https://www.redmine.org/news/135

And I change the Ruby runtime version to 3.1 with --jit option on Heroku.

If you have any issues with this change. Please comment this ticket or file to https://github.com/ruby/b.r-l.o/issues.

Thanks all.


Files

Screen Shot 2022-04-28 at 15.02.48.png (58.5 KB) Screen Shot 2022-04-28 at 15.02.48.png hsbt (Hiroshi SHIBATA), 04/28/2022 06:25 AM
Actions #1

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

I found the mailing-list integration is broken now.

Actions #2

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

  • Description updated (diff)

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

I fixed the issue of mailing-list integration.

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

  • Status changed from Open to Closed

I will mark this to closed because the basic feature works now.

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

  • Assignee set to hsbt (Hiroshi SHIBATA)

@nagachika (Tomoyuki Chikanaga) found the regression or behavior change of filter feature.

If you get the expected result like 3.0: REQUIRED with contained filter, you need to use quote like "3.0: REQUIRED".

Updated by zverok (Victor Shepelev) 4 months ago

Oh, _underscores_ are now back to meaning italic! Thank you, it was minor, but constant irritation after previous update (a year ago, I think?)

Updated by jaruga (Jun Aruga) 4 months ago

When I tried to upload a text file (make_q.log 444KB) on this ticket, I saw "Internal Server Error", and I couldn't upload the file.

Actions #8

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

  • Status changed from Closed to Open

Updated by hsbt (Hiroshi SHIBATA) 4 months ago

  • Status changed from Open to Closed

@jaruga (Jun Aruga) Thanks. I fixed it now.

Updated by jaruga (Jun Aruga) 4 months ago

Thanks. I fixed it now.

Thanks! I was able to upload files at https://bugs.ruby-lang.org/issues/18756 too now.

Actions

Also available in: Atom PDF