Project

General

Profile

Actions

Backport #2180

closed

request: add *Method#source_location to 1.8.x

Added by rogerdpack (Roger Pack) about 12 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:25965]

Description

=begin
Request:
Somewhat of a backport from 1.9, this is a request for the addition of {*Method, Proc}#source_location to 1.8

Should be doable using the MBARI6.patch
here
http://sites.google.com/site/brentsrubypatches/
Much thanks.
-r
=end


Files

source_location.diff (7.23 KB) source_location.diff nobu (Nobuyoshi Nakada), 10/07/2009 10:39 AM
Actions #1

Updated by nobu (Nobuyoshi Nakada) about 12 years ago

=begin
It's not a bug.
=end

Actions #2

Updated by rogerdpack (Roger Pack) about 12 years ago

=begin
Thanks nobu.
=end

Actions #3

Updated by rogerdpack (Roger Pack) almost 12 years ago

=begin
If somebody could look at the patch for this ticket, that would be much appreciated.
Thanks!
=end

Actions #4

Updated by nobu (Nobuyoshi Nakada) almost 12 years ago

  • Category set to core
  • Status changed from Open to Assigned
  • Assignee set to knu (Akinori MUSHA)
  • Target version set to Ruby 1.8.8

=begin

=end

Updated by shyouhei (Shyouhei Urabe) about 8 years ago

  • Description updated (diff)
  • Status changed from Assigned to Closed

This target version no lnger exists. I'd like to take this opportunity to thank you all.

Actions

Also available in: Atom PDF