Project

General

Profile

Bug #2786

Segfault when loading gem

Added by ryanb (Ryan Bates) over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.2dev (2010-02-24 trunk 26744) [x86_64-darwin10.0.0]
Backport:
[ruby-core:28322]

Description

=begin
I am occasionally getting a segfault error when using cucumber 0.6.2 with latest ruby trunk (26744) in Mac OS X 10.6.1. It is happening about 25% of the time I run the cucumber command. Here's the full error:

http://gist.github.com/312461#file_cucumber_segfault

From that error it looks like it is happening when calling the "gem" method and RubyGems is trying to raise an error when it can't find the gem. This is the line in cucumber (ansicolor.rb).

gem 'genki-ruby-terminfo'

I tried to duplicate this by executing that line in irb. I get a Gem::LoadError saying the gem doesn't exist but never a segfault there.

Sorry if this isn't the right place to post this ticket.
=end


Related issues

Related to Ruby master - Bug #2330: Non systematic segmentation fault with autoload rubyspecClosed11/04/2009Actions
Related to Ruby master - Bug #2976: cucumberでSEGVClosed03/18/2010Actions
Related to Ruby master - Bug #3132: …/nokogiri-1.4.1/ext/nokogiri/nokogiri.bundle: [BUG] Bus ErrorClosed04/12/2010Actions
Is duplicate of Ruby master - Bug #2529: Segmentation Fault is occasionally occurred in rake with cucumber and rspecClosed12/25/2009Actions

History

#1

Updated by dpickett (Dan PIckett) over 9 years ago

=begin
I can confirm this behavior as well with cucumber 0.6.4 and ruby trunk (27310) on Darwin 10.3 (OS X 10.6.3)
=end

#2

Updated by dpickett (Dan PIckett) over 9 years ago

=begin
here's the backtrace information: http://gist.github.com/363031
=end

#3

Updated by naruse (Yui NARUSE) over 9 years ago

  • Status changed from Open to Closed

=begin
This issue was solved with changeset r27393.
Kenta, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF