Project

General

Profile

Bug #3220

bug in gc.c

Added by tenderlovemaking (Aaron Patterson) over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.2dev (2010-04-29 trunk 27542) [x86_64-darwin10.3.0]
Backport:
[ruby-core:29874]

Description

=begin
I've attached a program that will segv during GC. It uses nokogiri version 1.4.1. I haven't figured out how to reproduce the bug without nokogiri, but this looks like a ruby bug.

I've also attached a gdb backtrace.
=end


Files

content.rb (183 Bytes) content.rb script for segv tenderlovemaking (Aaron Patterson), 04/29/2010 03:06 PM
bt.txt (9.84 KB) bt.txt gdb backtrace tenderlovemaking (Aaron Patterson), 04/29/2010 03:06 PM

History

#1

Updated by mdalessio (Mike Dalessio) over 9 years ago

=begin
I am unable to reproduce this with ruby 1.9.2dev (2010-04-29 trunk 27549) [i686-linux]

Indicating perhaps it's a 64-bit problem?

=end

#2

Updated by rogerdpack (Roger Pack) over 9 years ago

=begin
I am also unable to reproduce this in 32 bit environments...

http://gist.github.com/385231
=end

#3

Updated by wanabe (_ wanabe) over 9 years ago

  • Status changed from Open to Feedback

=begin
Can't reproduce with ruby 1.9.2dev (2010-05-04 trunk 27604) [x86_64-linux] on Ubuntu 10.04.
I guess this is not only 64-bit problem, but also OSX's.

Anyway,

Aaron, can you reproduce with the patch by Yusuke in #3241?
=end

#4

Updated by naruse (Yui NARUSE) over 9 years ago

  • Status changed from Feedback to Closed

=begin
[ruby-core:30082]
=end

Also available in: Atom PDF