Project

General

Profile

Bug #3272

BigDecimal#** が実用的な速度ではない

Added by mrkn (Kenta Murata) over 7 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3dev (2010-05-11 trunk 27729) [x86_64-darwin10.3.0]

Description

=begin
logは、exponentが負の場合、
を書いてあるから、正で2桁以上の場合、を追加すると良いですね。
expとlogが実用範囲内になると、実数**実数が(実用的に)使えるようになります。
=end


Related issues

Related to Ruby trunk - Bug #3267: BigDecimal/mathでatan()に1.08を入れると戻り値の有効桁数が足りないClosed2010-05-11
Is duplicate of Ruby trunk - Bug #3271: BigMath.power が遅いClosed2010-05-11

History

#1 [ruby-core:36977] Updated by ko1 (Koichi Sasada) about 6 years ago

中田さんが早くしろ,と言っています.

#2 [ruby-core:37527] Updated by nahi (Hiroshi Nakamura) about 6 years ago

  • Target version changed from 2.0.0 to 1.9.3

#3 [ruby-core:37950] Updated by mrkn (Kenta Murata) about 6 years ago

  • Status changed from Assigned to Closed

チケットが重複していました。

Also available in: Atom PDF