Bug #3701

Gem.find_files returns empty array

Added by Yusuke Endoh about 5 years ago. Updated over 4 years ago.

[ruby-core:31730]
Status:Closed
Priority:Normal
Assignee:Nobuyoshi Nakada
ruby -v:ruby 1.9.3dev (2010-08-15 trunk 28996) [i686-linux] Backport:

Description

=begin
Hi, Nobu and Evan

r28919 seemed to break Gem.find_files:

$ ../local/bin/ruby -e 'p Gem.find_files("*/.rb").size'
0

When I revert r28919 manually, it seems to work correctly:

$ ../local/bin/ruby -e 'p Gem.find_files("*/.rb").size'
1898

This issue actually make hoe(*) not work.

(*) http://seattlerb.rubyforge.org/hoe/

--
Yusuke Endoh mame@tsg.ne.jp
=end

History

#1 Updated by Evan Phoenix about 5 years ago

=begin
I just tested this code on trunk and it seems to work fine for me. Do you have any other information about it?

  • Evan

On Aug 16, 2010, at 10:21 AM, Yusuke Endoh wrote:

Bug #3701: Gem.find_files returns empty array
http://redmine.ruby-lang.org/issues/show/3701

Author: Yusuke Endoh
Status: Open, Priority: Normal
Assigned to: Nobuyoshi Nakada, Target version: 1.9.x
ruby -v: ruby 1.9.3dev (2010-08-15 trunk 28996) [i686-linux]

Hi, Nobu and Evan

r28919 seemed to break Gem.find_files:

$ ../local/bin/ruby -e 'p Gem.find_files("*/.rb").size'
0

When I revert r28919 manually, it seems to work correctly:

$ ../local/bin/ruby -e 'p Gem.find_files("*/.rb").size'
1898

This issue actually make hoe(*) not work.

(*) http://seattlerb.rubyforge.org/hoe/

Yusuke Endoh mame@tsg.ne.jp


http://redmine.ruby-lang.org

=end

#2 Updated by Nobuyoshi Nakada about 5 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r29017.
Yusuke, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

#3 Updated by Yusuke Endoh about 5 years ago

=begin
Hi,

2010/8/17 Evan Phoenix evan@fallingsnow.net:

I just tested this code on trunk and it seems to work fine for me. Do you have any other information about it?

Umm, I can't understand why you couldn't reproduce it.
"make install" may be needed to reproduce. Did you?

Anyway, nobu's fix (r29017) works for me. Thanks!

--
Yusuke Endoh mame@tsg.ne.jp

=end

Also available in: Atom PDF