Project

General

Profile

Backport #3709

Ruby 1.9.1 with openssl 1.0

Added by edmundhighcock (Edmund Highcock) over 8 years ago. Updated almost 8 years ago.

Status:
Assigned
Priority:
Normal
[ruby-core:31755]

Description

=begin
Hi,

The stable version of Ruby 1.9.1 that I have downloaded from http://www.ruby-lang.org/en/downloads/ does not have the latest openssl 1.0 patch applied and so will not compile with openssl 1.0.

The latest stable snapshot on the same page also won't compile with openssl 1.0.

openssl 1.0 is becoming a standard part of distributions (e.g. openSUSE 11.3) and so these two will start failing for more and more people.

Could the patch be applied to these two releases? I distribute a program which requires Ruby 1.9, and I would prefer it if my users didn't have to download the development version (or start applying patches themselves :-o )!

Also, I have tried applying the patch in Bug #3093 (http://redmine.ruby-lang.org/issues/show/3093) to the stable version, and it failed to fix the problem.

Thanks in advance,

Edmund
=end

History

#1

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Category set to ext
  • Status changed from Open to Assigned
  • Assignee set to yugui (Yuki Sonoda)

=begin

=end

Also available in: Atom PDF