Backport #3874

[PATCH] configure.in: Always add -mieee for Renesas SH4

Added by Nobuhiro Iwamatsu over 3 years ago. Updated over 2 years ago.

[ruby-core:32548]
Status:Closed
Priority:Low
Assignee:Yuki Sonoda

Description

=begin
SH4 is CPU for embedded which developed by Renesas Electronics.
SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.
=end

0001-configure.in-Always-add-mieee-for-Renesas-SH4.patch Magnifier (1.01 KB) Nobuhiro Iwamatsu, 09/25/2010 12:09 AM

Associated revisions

Revision 29340
Added by Motohiro KOSAKI over 3 years ago

configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874]

History

#1 Updated by Motohiro KOSAKI over 3 years ago

=begin
Comitted.

note, myself haven't tested this patch (and I can't get sh4 test environment in future too).
I believe you :)
=end

#2 Updated by Motohiro KOSAKI over 3 years ago

  • Status changed from Open to Closed
  • Assignee set to Motohiro KOSAKI

=begin
Ruby:r29340 (trunk)
=end

#3 Updated by Motohiro KOSAKI over 3 years ago

  • Category set to build
  • Status changed from Closed to Assigned
  • Assignee changed from Motohiro KOSAKI to Yuki Sonoda
  • Priority changed from Normal to Low
  • Target version set to 1.9.2

=begin
Please consider to backport this to 1.9.2, 1.9.1 and 1.8.7. because
- Debian need this patch
- the patch is very small. It has no regression risk.

=end

#4 Updated by Motohiro KOSAKI over 2 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r29340.
Nobuhiro, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


configure.in: Always add -mieee for Renesas SH4

SH4 is CPU for embedded which developed by Renesas Electronics.
Renesas SH4 has FPU. When FPU is used on sh4, -mieee of option is necessary.
This supports sh4(basic), sh4el(sh4 little endian) and sh4eb(sh4 big endian).
These do not have FPU though there are other sh4al, sh4al-dsp and etc.

[Feature #3874]

#5 Updated by Yui NARUSE over 2 years ago

  • Target version deleted (1.9.2)

Also available in: Atom PDF