Bug #4037

Net/http keep alive bug

Added by Michael Fellinger over 4 years ago. Updated almost 4 years ago.

[ruby-core:33108]
Status:Rejected
Priority:Normal
Assignee:Hiroshi Nakamura
ruby -v:ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux] Backport:

Description

=begin
I've found a bug where if the target server sends an eof to the socket, net/http will raise an error. I've attached
a sample script to prove the bug and a patch to fix it. I wrote the patch against 1.8, but I think it should apply
to 1.9.

-Aaron

(This bug is from https://rubyforge.org/tracker/index.php?func=detail&aid=17778&group_id=426&atid=1700 - I simply copied it here to get attention and proper tracking)

Some more information to reproduce the issue: http://pastie.org/1281626
=end

History

#1 Updated by Yui NARUSE over 4 years ago

  • Status changed from Open to Assigned
  • Assignee set to Aaron Patterson

=begin
Please commit this.
=end

#2 Updated by Koichi Sasada almost 4 years ago

Can we close it?

#3 Updated by Hiroshi Nakamura almost 4 years ago

  • Status changed from Assigned to Rejected
  • Assignee changed from Aaron Patterson to Hiroshi Nakamura

Sorry for late reply, and marking it as 'Rejected'. I'm just want to say that 'it's not a bug'. (We should have suitable label in the future.)

net/http requires to set 'use_ssl' flag manually before starting a connection.

require 'net/http'
c = Net::HTTP.new("accesspoint.atmosonline.com", 443)
c.use_ssl = true # HERE !!!
c.start
uri = URI::HTTP.build(:host => "accesspoint.atmosonline.com", :port => 443, :path => "/rest/objects", :query => "listabletags")
p c.request(Net::HTTP::Get.new(uri.request_uri, {}))

Also available in: Atom PDF