Project

General

Profile

Actions

Feature #403

closed

Add support to Haiku

Added by Anonymous over 14 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:18110]

Description

=begin
Here is a patch to compile ruby 1.9 under Haiku.

3 test cases still do not run. And network support is not yet fully working.

Here is the content of the patch :

  • more up to date config.guess et config.sub (maybe there is more recent
    ones in the autoconf repository)
  • different changes to recognize Haiku and configure ruby in autoconf scripts
  • some compile fix in various files
  • some compile fix in the socket extension

I hope it will help advocate the BeOS case at the next cleaning.

Pete Goodeve has already shown interest in the BeOS port too (http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/309735).
The only thing missing to compile 1.9 under BeOS is the lack
of a native thread implementation. There is only a partial pthread
library under BeOS. I will take a look at this in the next weeks,
but can't promise anything.

Haiku has a better POSIX layer, an almost complete pthread implementation
and is now stable enough to compile ruby directly.

If we have to choose, Haiku support is probably more important than BeOS one.

Olivier Coursière
=end


Files

ruby_1_9_haiku_r18321.patch (61.4 KB) ruby_1_9_haiku_r18321.patch Anonymous, 08/04/2008 04:07 AM
new_ruby_1_9_haiku.patch (7.92 KB) new_ruby_1_9_haiku.patch oco (Olivier Coursière), 08/05/2008 11:17 AM
new_ruby_1_9_haiku_config.sub_config.guess.patch (53.2 KB) new_ruby_1_9_haiku_config.sub_config.guess.patch oco (Olivier Coursière), 08/05/2008 11:17 AM
config.guess_automake-1.10.1.patch (438 Bytes) config.guess_automake-1.10.1.patch oco (Olivier Coursière), 08/05/2008 11:17 AM
Actions

Also available in: Atom PDF

Like0
Like0Like0Like0Like0Like0Like0Like0Like0