Bug #4519

rubygems/test_gem_package_task.rb breaks rake/test_filelist.rb

Added by Yutaka HARA about 3 years ago. Updated almost 3 years ago.

[ruby-core:35542]
Status:Closed
Priority:Normal
Assignee:Eric Hodel
Category:test
Target version:1.9.3
ruby -v:ruby 1.9.2p180 (2011-02-18 revision 30909) [i686-linux] Backport:

Description

=begin
test-all of Ruby 1.9.2 p180 fails as follows on CentOS 5.5.

testarraycomparisons(Rake::TestFileList) [/home/yhara/ruby-1.9.2-p180/test/rake/test_filelist.rb:462]:
expected but was
.

This happens when test/rubygems/ is executed before test/rake/.

To reproduce this: (tested on Ubuntu 10.10 and Mac OS X 10.5.8)

(1) Edit test/runner.rb as follows
(2) make test-all

(...snip...)
Test::Unit.setup_argv {|files|
(...snip...)
end

["test/rubygems/testgempackagetask.rb", "test/rake/testfilelist.rb"]
}

=end

History

#1 Updated by Yui NARUSE about 3 years ago

  • Status changed from Open to Assigned
  • Assignee set to Eric Hodel

=begin

=end

#2 Updated by Hiroshi Nakamura almost 3 years ago

  • Target version changed from 1.9.2 to 1.9.3

#3 Updated by Eric Hodel almost 3 years ago

  • Status changed from Assigned to Closed

I cannot reproduce this, I think it has been fixed.

$ make test-all TESTS='rubygems rake -v'
./miniruby -I./lib -I. -I.ext/common ./tool/runruby.rb --extout=.ext -- "./test/runner.rb" --ruby="./miniruby -I./lib -I. -I.ext/common ./tool/runruby.rb --extout=.ext --" rubygems rake -v
Run options: "--ruby=./miniruby -I./lib -I. -I.ext/common ./tool/runruby.rb --extout=.ext --" -v

Running tests:

TestConfig#testdatadir = 0.00 s = .
TestGem#test
requiremissing = 0.00 s = .
TestGem#test
selfactivateambiguousindirectconflict = 0.03 s = .

Finished tests in 24.422676s, 51.7552 tests/s, 162.2263 assertions/s.

1264 tests, 3962 assertions, 0 failures, 0 errors, 0 skips
$

Also available in: Atom PDF