Bug #5168

libc and libm path in test/dl and test/fiddle on Solaris

Added by Naohisa Goto over 2 years ago. Updated over 2 years ago.

[ruby-core:38853]
Status:Closed
Priority:Normal
Assignee:Naohisa Goto
Category:test
Target version:1.9.3
ruby -v:- Backport:

Description

In test/dl/test_base.rb, "libc.so.6" and "libm.so.6" are used for Solaris, but sparc Solaris only have libc.so.1 and libm.so.2.
I don't know what version number on Intel x86 Solaris, so I simply removed the version numbers. (file test-dl-libc-solaris.patch)

Similar code is found in test/fiddle/test_base.rb, but no code for Solaris.
Patch attached. (file test-fiddle-libc-solaris.patch)

test-dl-libc-solaris.patch Magnifier (567 Bytes) Naohisa Goto, 08/08/2011 11:02 PM

test-fiddle-libc-solaris.patch Magnifier (718 Bytes) Naohisa Goto, 08/08/2011 11:02 PM

noname (500 Bytes) Aaron Patterson, 08/09/2011 06:23 AM

Associated revisions

Revision 32893
Added by Naohisa Goto over 2 years ago

History

#1 Updated by Aaron Patterson over 2 years ago

  • ruby -v changed from ruby 1.9.3dev (2011-08-08) [sparc-solaris2.10] to -

On Mon, Aug 08, 2011 at 11:02:45PM +0900, Naohisa Goto wrote:

Issue #5168 has been reported by Naohisa Goto.


Bug #5168: libc and libm path in test/dl and test/fiddle on Solaris
http://redmine.ruby-lang.org/issues/5168

Author: Naohisa Goto
Status: Open
Priority: Normal
Assignee: Aaron Patterson
Category:
Target version:
ruby -v: ruby 1.9.3dev (2011-08-08) [sparc-solaris2.10]

In test/dl/test_base.rb, "libc.so.6" and "libm.so.6" are used for Solaris, but sparc Solaris only have libc.so.1 and libm.so.2.
I don't know what version number on Intel x86 Solaris, so I simply removed the version numbers. (file test-dl-libc-solaris.patch)

Similar code is found in test/fiddle/test_base.rb, but no code for Solaris.
Patch attached. (file test-fiddle-libc-solaris.patch)

Yes, feel free to commit this. :-)

--
Aaron Patterson
http://tenderlovemaking.com/

#2 Updated by Motohiro KOSAKI over 2 years ago

  • Category set to test
  • Status changed from Open to Assigned
  • Assignee changed from Aaron Patterson to Naohisa Goto
  • Target version set to 1.9.3

Goto-san, A test fix still can be commited into 193 branch if you want. Because it has no regression risk.

Thanks.

#3 Updated by Naohisa Goto over 2 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r32893.
Naohisa, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


Also available in: Atom PDF