Bug #5251

Thread Change Breaks Windows Builds

Added by Charlie Savage over 2 years ago. Updated over 2 years ago.

[ruby-core:39195]
Status:Closed
Priority:Urgent
Assignee:Motohiro KOSAKI
Category:core
Target version:1.9.3
ruby -v:ruby 1.9.3dev (2011-08-26 revision 33077) [i386-mingw32] Backport:

Description

This commit:

Commit:4e9438bc9153f7a1f4ea0af85c8dbe359e1a55d8

Causes this error:

thread.c: In function rb_thread_select':
thread.c:2685: warning: missing braces around initializer
thread.c:2685: warning: (near initialization for
fdsets[0]')
thread.c:2693: error: implicit declaration of function `rbfdcopy'
make: *** [thread.o] Error 1

Using mingw, with this gcc:

gcc version 3.4.5 (mingw-vista special r3)

Note that in thread.c, rbfdcopy is not defined for win32, and therefore, this breaks. Thus, this would break for msvc also it looks.


Related issues

Related to ruby-trunk - Bug #5229: [PATCH] thread.c (rb_thread_select): implement using rb_t... Closed 08/25/2011

History

#1 Updated by Motohiro KOSAKI over 2 years ago

  • Status changed from Open to Assigned
  • Priority changed from Normal to Urgent

#2 Updated by Motohiro KOSAKI over 2 years ago

  • Status changed from Assigned to Closed

This regression was caused by Bug#5229(rbthreadselect() rewritten) and fixed by r33128, r33130, r33131, r33132, r33133.

Thank you, Usa-san!

#3 Updated by Eric Wong over 2 years ago

Motohiro KOSAKI kosaki.motohiro@gmail.com wrote:

This regression was caused by Bug#5229(rbthreadselect() rewritten)
and fixed by r33128, r33130, r33131, r33132, r33133.

Oops, sorry all, I'm a klutz :x

Also available in: Atom PDF